Page MenuHomePhabricator

Suggested Edits analytics not working in 2.7.50308
Closed, ResolvedPublicBUG REPORT

Description

I was going to demonstrate to Shay how the suggested items & taps on them are counted in the suggested edits analytics, but after I exited the SE screen (running DevDebug build), only FeedFunnel events were present in logcat. I tried it a few more times but there was nothing from SuggestedEditsFunnel in logcat.

I checked the events in the database and we have 1 event from 2.7.50308-beta-2020-01-06 and that singular event has "source":"suggestedEdits", so clearly something is not working as intended. (Side note: how does one arrive at a Suggested Edits screen from another Suggested Edits screen?)

Stack trace

Nothing from SuggestedEditsFunnel

Environments observed

App version: 2.7.50308-beta-2020-01-06

Event Timeline

mpopov created this task.Jan 7 2020, 5:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 7 2020, 5:26 PM
mpopov triaged this task as Unbreak Now! priority.Jan 7 2020, 5:26 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJan 7 2020, 5:26 PM
ABorbaWMF added a subscriber: ABorbaWMF.

Looks ok from my side on 2.7.50308-beta-2020-01-06

mpopov added a subscriber: Dbrant.EditedJan 31 2020, 4:35 PM

I re-created an emulator, made sure all my SDKs are updated, pulled the latest version from GitHub, and on 2.7.50309-dev-2020-01-31 I'm still not seeing any MobileWikiAppSuggestedEdits events in Logcat, but am seeing MobileWikiAppFeed events. This makes me worried because if Suggested Edits analytics isn't logging things to Logcat then it implies that it's not working as intended.

@Dbrant @cooltey: can you please check if you're seeing the same?

Dbrant closed this task as Resolved.Feb 3 2020, 2:27 PM
Charlotte reopened this task as Open.Feb 4 2020, 6:39 PM
Charlotte removed cooltey as the assignee of this task.
Charlotte added a subscriber: cooltey.
Charlotte added a subscriber: Charlotte.

@Dbrant looked into this - can you tell us what you found? If there's some disconnect between events the app is sending, and what we're seeing in analytics, we do need to work it out.

Also just to mention, you can see recent gaps in the data series in some, but not all of the graphs here, e.g. the Suggestion Clickthrough Rate: https://analytics.wikimedia.org/published/datasets/wikipedia-android-app-reports/suggested-edits-v2.html

Not sure if related... it's weird though.

Dbrant added a comment.Feb 4 2020, 7:32 PM

I can confirm that the SuggestedEdits events seem to be functioning as expected, and can be seen coming through in Logcat, as well as being received on the server side, at least when looking at the deployment testing server (deployment-eventlog05).

mpopov closed this task as Resolved.Feb 5 2020, 5:49 PM
mpopov claimed this task.

Thanks, all! Glad to hear the good news that everything is a-OK, but bummed about the bad news of apparently something is just very wrong with the development environment on my end. Sorry for the confusion, folks!