Page MenuHomePhabricator

translatewiki-rake-docker failing: Gem::InstallError: gettext requires Ruby version >= 2.5.0.
Closed, ResolvedPublic

Description

This seems to have started today. Patches that passed yesterday are now failing, so it's shouldn't be caused by our code.

Details

Related Gerrit Patches:
translatewiki : masterUnbreak translatewiki-rake-docker

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 9 2020, 1:12 PM

Change 563173 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[translatewiki@master] Unbreak translatewiki-rake-docker

https://gerrit.wikimedia.org/r/563173

Change 563173 merged by jenkins-bot:
[translatewiki@master] Unbreak translatewiki-rake-docker

https://gerrit.wikimedia.org/r/563173

Merged, I'll be tested on a new vagrant box later next week.

Upstream says:

Your Bundler is old:

13:08:00 Using bundler 1.13.6

The latest Bundler (2.1.4) doesn't have the problem.

Nikerabbit triaged this task as High priority.Jan 15 2020, 2:15 PM
Nikerabbit renamed this task from translate-rake-docker failing: Gem::InstallError: gettext requires Ruby version >= 2.5.0. to translatewiki-rake-docker failing: Gem::InstallError: gettext requires Ruby version >= 2.5.0..Tue, Jan 21, 11:23 AM
Pginer-WMF closed this task as Resolved.Tue, Feb 18, 8:41 AM
Pginer-WMF claimed this task.