Page MenuHomePhabricator

Feature Request: Expiration date for short links
Closed, DeclinedPublic

Description

If the user don't need the short URL for a long time he can set a radio button to let the URL expire after 7/30/90/never days

Event Timeline

Der_Keks created this task.Jan 10 2020, 8:55 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 10 2020, 8:55 PM

Another solution is a checkbox "Delete when not called for <number-of-days> days".

Aklapper changed the task status from Open to Stalled.Jan 10 2020, 9:33 PM

Which underlying problem would this proposed solution solve, and how would that outweigh the "That short link is a 404 now!" problem?

Der_Keks added a comment.EditedJan 10 2020, 9:40 PM

I didn't knew how to link meaningfully to T242465, then I forgot it... There are cases where I just need the shortURL for one or two guys in single use to tell them the URL via telephone. Such links aren't needed to live forever but others may like to have w.wiki/HB for a permanent solution like the example in T242465.

Which problem would be created if those links are live forever?

Unused links could not be reused like described in T242465 but as you showed me it seems not welcome to have custom shortURLs.

Unused links could not be reused

Why would anyone want to "reuse" URLs? Cool URIs don't change.

Please see T242465 for an example case. You know I am not alone, you closed the Task as duplicate of T229064. Please see also T44085#5127606. There are cases and they are described in the Tasks that were closed.

I have seen T242465, I just don't understand how it is related to this task.

This is against HTTP standard, a URI should stay consistent and we can't make w.wiki/Foo to something and then to something else later. Not to mention immutability gives us performance gains in DB level like replication, locking and integrity checking. I'm very much decline this ticket.

I have seen T242465, I just don't understand how it is related to this task.

Ok let's assume that Bob has a local community place of the german wikipedia in berlin and he call it "wikibär". For marketing reasons he want to refer to the wikibär-page at dewiki and print a shortlink with QR-Code on it. A few weeks ago Alice just created the shortURL (generated w.wiki/wbaer after wbaep and wbaeq) to write it down on paper for a friend instead of writing down https://en.wikipedia.org/wiki/%2290th_Anniversary_of_the_Armed_Forces_of_Azerbaijan_(1918-2008)%22_Medal Alice' friend needs this link only once. Bob now would have no chance to get w.wiki/wbaer because it's blocked by an article to the 90th Anniversary of something but never used again. But Alice was pleasant and nice; she checked "Delete when not called for 7 days" so that w.wiki/wbaer is available again. With T242465 Bob would now be able to say that he want's to have w.wiki/wbaer.
You are right: This feature itself is useless. But related to T242465 it has a reason.

This is against HTTP standard, a URI should stay consistent and we can't make w.wiki/Foo to something and then to something else later.

Is this a Problem? It's still practised:

Just because someone provides a bad example does not mean that we must follow that bad example.

Aklapper closed this task as Declined.Jan 11 2020, 2:14 PM

I'm going to boldly decline this task as so far there have been no arguments provided which actual underlying problem would get solved by adding this feature, given the problems that this feature would clearly create.