Page MenuHomePhabricator

Repeated 503 Errors
Closed, ResolvedPublicBUG REPORT

Description

For the last couple of days, I have been getting a 503 error when I try to access the SVG Translate tool.

Steps to Reproduce:

  1. Go to https://tools.wmflabs.org/svgtranslate/

Actual Results:


(Also, the title says "503 Service Unavailable")

Expected Results:

The tool to work as it previously did

I have been accessing the tool through Firefox 71 and 72.

Event Timeline

MSG17 created this task.Sat, Jan 11, 3:55 AM
Restricted Application added a project: Community-Tech. · View Herald TranscriptSat, Jan 11, 3:55 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
MSG17 updated the task description. (Show Details)Sat, Jan 11, 3:56 AM
Masumrezarock100 triaged this task as Unbreak Now! priority.Sun, Jan 12, 3:22 PM

Boldly setting the priority to unbreak now since the tool is literally unfunctionable at the moment. CC-ing @MusikAnimal .

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptSun, Jan 12, 3:22 PM
MusikAnimal closed this task as Resolved.Sun, Jan 12, 3:50 PM
MusikAnimal claimed this task.
MusikAnimal moved this task from Backlog to Done on the SVG Translate Tool board.

Apologies it took so long to tend to this! A simple restart did the trick. There's nothing relevant in the error logs, so I've no idea why this happened... but I have added this tool to our monitoring service so we will get notified if it goes down again.