Page MenuHomePhabricator

Disable VisualEditor on Polish Wiktionary
Closed, ResolvedPublic

Description

VisualEditor is a tools designed to work with Wikipedia, not Wiktionary. Trying to edit a Wiktionary page with VE breaks the code of the page.

Thus, the community of Polish Wiktionary is asking you to disable it there. See here: https://pl.wiktionary.org/wiki/Wikis%C5%82ownik:Bar/Dyskusje_techniczne#Wy%C5%82%C4%85czenie_VE.

Regards.

Event Timeline

PiotrekD created this task.Jan 11 2020, 3:46 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 11 2020, 3:46 PM
Aklapper added a comment.EditedJan 11 2020, 3:57 PM

Trying to edit a Wiktionary page with VE breaks the code of the page.

Is there a bug report with clear and exact steps to reproduce that problem? I'd prefer to fix root problems instead of workaround solutions. :)

Furthermore, it is unclear to me what "disable" would mean. Changing the default editor? For newly registered users only? Or overwriting it for all users? Or only those users who have not changed their default editor settings?

There's no bug report as far as I know.

We want to have the old wikitext editor set as the default editor for both the logged-in and the logged-out.

Wargo added a subscriber: Wargo.Jan 11 2020, 4:06 PM

Wiktionary uses multiple templates and editing that structure with VE is difficult for users, the editor is just not designed to content that is not in page directly.

Urbanecm changed the task status from Open to Stalled.Jan 11 2020, 4:14 PM
Urbanecm added subscribers: Jdforrester-WMF, Urbanecm.

I'd like to hear @Jdforrester-WMF's comment at this one.

JTannerWMF added subscribers: ppelberg, JTannerWMF.

@ppelberg will determine what to do with this from the Editing-team perspective

I had a closer look at this task after @PiotrekD asked me to push it forward.

(This is definitely a reasonable request, VisualEditor doesn't work well with Wiktionary pages, which are composed almost entirely of templates.)

First of all, "disable" is ambiguous, and your clarification in T242514#5794808 ("have the old wikitext editor set as the default editor") doesn't help because I tried it and wikitext editor is already the default :D So I looked at the discussion to try to find out what exactly is requested: (translation and emphasis mine)

I would like to propose a change in the Wiktionary configuration to make the wikicode editor the default page editor for all users (logged in and out). At present it is the case that when you open the edit window, a window with a question about the edit mode pops up. People (…) who have just created an account and have not yet changed anything in their preferences, can choose which editing mode to use. And they often choose VE.
(…)
I suggest, therefore, like in the introduction: to change the configuration of the page so that the wikitext editor is set by default for everyone without asking about the editing mode. At the same time, there will remain the option to enable VE in the account preferences, if someone wants it very much. (…)

I had a look at the code, and we don't currently have a configuration option for that. However, the behavior seems weird to me. On Polish Wiktionary, VisualEditor is supposed to be in opt-in mode (you have to turn on the beta feature to access it). Surely we shouldn't be prompting users to switch to it?

Compare this to French Wiktionary. As a result of T65187 and T169741, the configuration there is that VisualEditor is enabled for everyone, but wikitext is the default. But in practice, it seems to behave exactly like Polish Wiktionary, where VisualEditor is opt-in. Surely they should behave differently?

I think displaying the option to switch editors is a bug. I filed T243723 with the details. We'll be busy this week at the WMF All Hands meeting, but I'll try to get back to this soon afterwards.

This should be fixed now (see the subtask for details). Can you confirm it works as expected on Polish Wiktionary?

matmarex changed the task status from Stalled to Open.Mar 3 2020, 1:25 AM

I can confirm this is working as expected, thanks!

matmarex closed this task as Resolved.Mar 15 2020, 5:09 PM
matmarex claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMar 15 2020, 5:09 PM