Page MenuHomePhabricator

requestretry 4.1.0 breaks compatibility with node 6
Closed, ResolvedPublic

Description

Latest version 4.1.0 of the requestretry package, a dependency of preq, uses async/await syntax, and is therefore not compatible with node 6. This breaks CI builds for mobileapps and probably for lots of other services, too.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 563981 had a related patch set uploaded (by Mholloway; owner: Michael Holloway):
[mediawiki/services/mobileapps@master] Hold back various dependencies for node/npm version compatibility

https://gerrit.wikimedia.org/r/563981

Change 563981 merged by jenkins-bot:
[mediawiki/services/mobileapps@master] Hold back various dependencies for node/npm version compatibility

https://gerrit.wikimedia.org/r/563981

Mholloway claimed this task.

preq was updated to account for this.