Page MenuHomePhabricator

mediawiki/mediawiki-codesniffer >= 28 causing travis failures in repos which still think they support PHP < 7.2
Closed, DeclinedPublic

Description

Noticed on wikimedia/xmp-reader, as it still supports PHP >= 5.6.99, testing on 7.0, 7.1 and hhvm. mediawiki/mediawiki-codesniffer >= 28 needs PHP 7.2

https://travis-ci.org/wikimedia/xmp-reader/builds/601743715

Problem 1
  - Installation request for mediawiki/mediawiki-codesniffer 28.0.0 -> satisfiable by mediawiki/mediawiki-codesniffer[v28.0.0].
  - v28.0.0 requires php >= 7.2.0 -> your PHP version (7.0.33) does not satisfy that requirement.

Event Timeline

I guess this is kind of a bug in PHPCS bumping... There's not much point bumping PHPCS version if the php version causes a conflict...

I guess this is kind of a bug in PHPCS bumping... There's not much point bumping PHPCS version if the php version causes a conflict...

Mostly this is just flagging that I need to drop 7.1 and below support from XMPReader.

I guess this is kind of a bug in PHPCS bumping... There's not much point bumping PHPCS version if the php version causes a conflict...

Mostly this is just flagging that I need to drop 7.1 and below support from XMPReader.

And I suspect numerous other libraries too suffered a similar fate

I guess this is kind of a bug in PHPCS bumping... There's not much point bumping PHPCS version if the php version causes a conflict...

Mostly this is just flagging that I need to drop 7.1 and below support from XMPReader.

And I suspect numerous other libraries too suffered a similar fate

https://github.com/search?q=org%3Awikimedia+%27hhvm-3.18%27&type=Code doesn't have many hits. Will go kill some off.

libup has also a list of php in the required field of composer: https://libraryupgrader2.wmflabs.org/library/composer/php

That's a little buggy. ">= version" and ">=version" aren't grouped together

Jdforrester-WMF renamed this task from mediawiki/mediawiki-codesniffer >= 28 causing travis failures in libraries to mediawiki/mediawiki-codesniffer >= 28 causing travis failures in repos which still think they support PHP < 7.2.Jan 17 2020, 12:54 AM
Krinkle subscribed.

We no longer run our tests on Travis.