Page MenuHomePhabricator

Newcomer tasks: article counter in Start editing dialog footer displays more than 200
Closed, ResolvedPublic

Description

According to the specs in T242418: Newcomer tasks: add article counter to footer of start editing dialog - the max number of articles available for editing shown to users should always be 200 (the current limit).

  1. On cswiki betalabs click on "See suggested edits" to open "Suggested edits to get started" dialog
  2. Don't make any selection - the counter in the footer will briefly show 200, which then will be changing to 3,398.
  3. Select all topics - the number changes to 7,329

(click on the animated gif - it shows how 200 changes to 3,398)

Note:

  • opening the intro dialog again (after Cancel) will display only 3,398
  • when a user clicks on Done, the 'Suggested edits' module will display 200

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 17 2020, 12:14 AM
Aklapper renamed this task from Nwecomer tasks: article counter in Start editing dialog footer displays more than 200 to Newcomer tasks: article counter in Start editing dialog footer displays more than 200.Jan 17 2020, 12:27 AM
Tgr added a subscriber: Tgr.Jan 17 2020, 7:16 AM

This is the same as T242814: Newcomer tasks: Discrepancy in article counter on "Select your interests" : we display the real result count (how many matching articles are there on the server), not the task card count.

This is the same as T242814: Newcomer tasks: Discrepancy in article counter on "Select your interests" : we display the real result count (how many matching articles are there on the server), not the task card count.

I still think that it is still a valid case to improve user experience

  • the current behavior of the counter does not follow the spec in T242418
  • 200 count which is briefly flashes on the intro card should not be displayed
  • users should be informed that the task card displays only 200; otherwise the discrepancy in between "how many matching articles are there on the server" and 200 on the task count looks confusing

I'll re-check the behavior in wmf.16 (and, probably, wait for users' feedback).

Tgr added a comment.Jan 22 2020, 10:27 PM
  • the current behavior of the counter does not follow the spec in T242418

The issue of showing numbers higher than 200 was fixed last week, I think.

  • 200 count which is briefly flashes on the intro card should not be displayed

That should be fixed as part of T236842: Newcomer tasks: Animate the "live broadcast" icon in the Suggested edits results overlay .

  • users should be informed that the task card displays only 200; otherwise the discrepancy in between "how many matching articles are there on the server" and 200 on the task count looks confusing

We could show something like "200+" or "more than 200". But that should probably discussed separately.

With respect to @Tgr's last point, I filed this: T242889: Newcomer tasks: upgrades to article counter

The other points are with @Etonkovidova for QA.

Etonkovidova closed this task as Resolved.Feb 6 2020, 12:48 AM
Etonkovidova claimed this task.

Re-checked in betalabs and production - the issue is not present anymore.