Page MenuHomePhabricator

python3.4 broken on deployment-logstash2
Closed, ResolvedPublic

Description

Setting up python3.4 (3.4.2-1+deb8u3) ...
  File "/usr/lib/python3.4/http/client.py", line 1014
    raise InvalidURL(f"URL can't contain control characters. {url!r} "
                                                                     ^
SyntaxError: invalid syntax
dpkg: error processing package python3.4 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 python3.4
E: Sub-process /usr/bin/dpkg returned an error code (1)

Event Timeline

Reedy created this task.Jan 17 2020, 1:31 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 17 2020, 1:31 AM

we should probably stop trying to fix problems with this instance and aim to shut it down, have people fix logstash03 instead?

Krenair added a comment.EditedJan 17 2020, 1:35 AM

(IIRC f-strings are python 3.6 so I'm not sure how this has shown up in a python3.4 directory, am guessing newer instances would not have this problem as they'd have newer python)

MoritzMuehlenhoff triaged this task as Medium priority.Jan 17 2020, 8:10 AM
faidon added a subscriber: faidon.Jan 17 2020, 9:46 AM

I've seen this issue before, and if I recall correctly, it was an issue with the Python 3.4 backport. I think the latest backport for 3.4.10-1~stretch1 should fix it.

All that said, it's 2020, and spending time for Python 3.4 (and on stretch) is Just Wrong™ IMHO. YMMV :)

Reedy closed this task as Resolved.Jan 17 2020, 11:25 AM
Reedy claimed this task.

All that said, it's 2020, and spending time for Python 3.4 (and on stretch) is Just Wrong™ IMHO. YMMV :)

How long was python 2 supported for? ;)

Updating to 3.4.2-1+deb8u7 seems to have cleared the issue. Thanks!