Page MenuHomePhabricator

Math master is currently broken due to a Wikibase change
Closed, ResolvedPublic

Description

As observed in r565622, tests currently fail on Math because of:

PHP Fatal error: Declaration of MathMLRdfBuilder::addValue(Wikimedia\Purtle\RdfWriter $writer, $propertyValueNamespace, $propertyValueLName, $dataType, Wikibase\DataModel\Snak\PropertyValueSnak $snak) must be compatible with Wikibase\Rdf\ValueSnakRdfBuilder::addValue(Wikimedia\Purtle\RdfWriter $writer, $propertyValueNamespace, $propertyValueLName, $dataType, $snakNamespace, Wikibase\DataModel\Snak\PropertyValueSnak $snak) in /workspace/src/extensions/Math/src/MathMLRdfBuilder.php on line 7

This failure is clearly not spurious, and was caused by r533202 for Wikibase. I'm unsure what the fix is [1], but either way, this needs to be fixed before the next train.

[1] - Maybe just adding that extra parameter would suffice, but I'm no confident enough with Wikibase to know if that's true.

Event Timeline

Daimona created this task.Jan 18 2020, 1:32 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 18 2020, 1:32 PM
Reedy added a subscriber: Reedy.Jan 18 2020, 1:42 PM

[1] - Maybe just adding that extra parameter would suffice, but I'm no confident enough with Wikibase to know if that's true.

I would imagine so. It seems odd to not add the new parameter at the end of the argument list too...

Shouldn’t blockers be UBN!?

RhinosF1 triaged this task as Unbreak Now! priority.Jan 18 2020, 1:52 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJan 18 2020, 1:52 PM

Change 565732 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/Math@master] Add $snakNamespace parameter to ValueSnakRdfBuilder implementer

https://gerrit.wikimedia.org/r/565732

Physikerwelt lowered the priority of this task from Unbreak Now! to Medium.Jan 18 2020, 6:27 PM
Physikerwelt added a subscriber: Physikerwelt.

I think this is not ubn. Why not disable the test?

Daimona raised the priority of this task from Medium to Unbreak Now!.Jan 18 2020, 6:44 PM

I think this is not ubn. Why not disable the test?

Because it's not a faulty test: there's a signature mismatch, and it will produce a PHP warning (at least) as soon as the file is loaded. I believe this is enough to qualify as train blocker, hence ubn.

Change 565888 had a related patch set uploaded (by WMDE-leszek; owner: WMDE-leszek):
[mediawiki/extensions/Math@master] Adjust method signature in MathMLRdfBuilder

https://gerrit.wikimedia.org/r/565888

Change 565888 abandoned by WMDE-leszek:
Adjust method signature in MathMLRdfBuilder

Reason:
duplicate

https://gerrit.wikimedia.org/r/565888

Change 565732 merged by jenkins-bot:
[mediawiki/extensions/Math@master] Add $snakNamespace parameter to ValueSnakRdfBuilder implementer

https://gerrit.wikimedia.org/r/565732

WMDE-leszek closed this task as Resolved.Jan 20 2020, 9:22 AM
WMDE-leszek claimed this task.

https://gerrit.wikimedia.org/r/565732 has fixed it. Apologies for the inconvenience.

WMDE-leszek removed WMDE-leszek as the assignee of this task.Jan 20 2020, 9:22 AM

Change 565992 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/MathSearch@master] Add $snakNamespace parameter to ValueSnakRdfBuilder implementer

https://gerrit.wikimedia.org/r/565992

Found another similar case in the MathSearch extension and decided to attach it to this task instead of creating a separate one (though it’s not as critical, since that extension isn’t deployed in production yet, as far as I’m aware).

Change 565992 merged by jenkins-bot:
[mediawiki/extensions/MathSearch@master] Add $snakNamespace parameter to ValueSnakRdfBuilder implementer

https://gerrit.wikimedia.org/r/565992

Yarfpr updated the task description. (Show Details)Feb 4 2020, 6:26 PM
Reedy updated the task description. (Show Details)Feb 4 2020, 6:28 PM