Page MenuHomePhabricator

Remove Backward compatibility code (MW < 1.33) in the Translate extension
Closed, ResolvedPublic

Description

Now that Mediawiki 1.34 has been released, we can remove code written to maintain support for MediaWiki < 1.33

We should also update the extension.json to reflect the new requirements.

Details

Related Gerrit Patches:
mediawiki/extensions/Translate : masterRemove B/C code written for MW < 1.33

Event Timeline

abi_ created this task.Jan 20 2020, 6:12 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 20 2020, 6:12 AM
abi_ renamed this task from Remove Backward compatibility code in the Translate extension to Remove Backward compatibility code (MW < 1.33) in the Translate extension.Jan 20 2020, 6:13 AM

Change 565267 had a related patch set uploaded (by Abijeet Patro; owner: Abijeet Patro):
[mediawiki/extensions/Translate@master] Remove B/C code written for MW < 1.33

https://gerrit.wikimedia.org/r/565267

Change 565267 merged by jenkins-bot:
[mediawiki/extensions/Translate@master] Remove B/C code written for MW < 1.33

https://gerrit.wikimedia.org/r/565267

abi_ closed this task as Resolved.Feb 3 2020, 4:13 AM

This has been deployed on various MediaWiki sites for a while. We've not received any reports of any issues.