Page MenuHomePhabricator

Error: "Call to a member function getName() on null" (from GrowthExperiments Mentorship.php)
Closed, ResolvedPublic

Description

Error

MediaWiki version: 1.35.0-wmf.15

message
Error: Call to a member function getName() on null
exception.trace
#0 /srv/mediawiki/php-1.35.0-wmf.15/extensions/GrowthExperiments/includes/HomepageModules/Mentorship.php(67): GrowthExperiments\HomepageModules\Mentorship->getMentorUsernameElement(boolean)
#1 /srv/mediawiki/php-1.35.0-wmf.15/extensions/GrowthExperiments/includes/HomepageModules/BaseModule.php(142): GrowthExperiments\HomepageModules\Mentorship->getBody()
#2 /srv/mediawiki/php-1.35.0-wmf.15/extensions/GrowthExperiments/includes/HomepageModules/BaseModule.php(75): GrowthExperiments\HomepageModules\BaseModule->renderMobileDetailsForOverlay()
#3 /srv/mediawiki/php-1.35.0-wmf.15/extensions/GrowthExperiments/includes/Specials/SpecialHomepage.php(377): GrowthExperiments\HomepageModules\BaseModule->getJsData(string)
#4 /srv/mediawiki/php-1.35.0-wmf.15/extensions/GrowthExperiments/includes/Specials/SpecialHomepage.php(174): GrowthExperiments\Specials\SpecialHomepage->outputJsData(string, array)
#5 /srv/mediawiki/php-1.35.0-wmf.15/includes/specialpage/SpecialPage.php(575): GrowthExperiments\Specials\SpecialHomepage->execute(NULL)
#6 /srv/mediawiki/php-1.35.0-wmf.15/includes/specialpage/SpecialPageFactory.php(611): SpecialPage->run(NULL)
#7 /srv/mediawiki/php-1.35.0-wmf.15/includes/MediaWiki.php(298): MediaWiki\Special\SpecialPageFactory->executePath(Title, RequestContext)
#8 /srv/mediawiki/php-1.35.0-wmf.15/includes/MediaWiki.php(967): MediaWiki->performRequest()
#9 /srv/mediawiki/php-1.35.0-wmf.15/includes/MediaWiki.php(530): MediaWiki->main()
#10 /srv/mediawiki/php-1.35.0-wmf.15/index.php(46): MediaWiki->run()
#11 /srv/mediawiki/w/index.php(3): require(string)
#12 {main}

Details

Request ID
XiiiTwpAAD8AAEMwWhcAAABD
Request URL
https://ar.m.wikipedia.org/w/index.php?title=…&source=specialcontributions
Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : masterDo not call render methods when the module might not be set up

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 22 2020, 7:42 PM
Tgr claimed this task.Jan 22 2020, 10:36 PM
Tgr edited projects, added Growth-Team (Current Sprint); removed Growth-Team.

Probably caused by rEGRE7c36ad586104: Allow modules to export arbitrary module data, not just overlays. Not too serious as it only affects users with no mentor, but it's a production error so let's get it fixed soon.

Change 566632 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/extensions/GrowthExperiments@master] Do not call render methods when the module might not be set up

https://gerrit.wikimedia.org/r/566632

Change 566632 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Do not call render methods when the module might not be set up

https://gerrit.wikimedia.org/r/566632

Krinkle renamed this task from wmf.15/extensions/GrowthExperiments/includes/HomepageModules/Mentorship.php: Call to a member function getName() on null to Error: "Call to a member function getName() on null" (from GrowthExperiments Mentorship.php).Jan 23 2020, 11:51 AM
Krinkle changed Request URL from https://ar.wikipedia.org/w/index.php?title=%D8%AE%D8%A7%D8%B5:%D8%B5%D9%81%D8%AD%D8%A9_%D8%B1%D8%A6%D9%8A%D8%B3%D9%8A%D8%A9&source=specialcontributions to https://ar.m.wikipedia.org/w/index.php?title=…&source=specialcontributions.
Krinkle updated the task description. (Show Details)
Krinkle edited Stack Trace. (Show Details)
Etonkovidova closed this task as Resolved.Tue, Feb 11, 9:48 PM

Checked in wmf.18.