Page MenuHomePhabricator

Set selected MenuTagMultiselectWidget items as options in the constructor
Closed, ResolvedPublic

Description

The TitlesMultiselectWidget adds any selected items as tags when constructing a new widget. As the accompanying comment states, this should be upstreamed to its parent, MenuTagMultiselectWidget, since other subclasses should also do this too. (Not doing this in the UsersMultiselectWidget is the cause of T243075#5829744.)

TitlesMW and UsersMW are in core, but MenuTagMW (the parent) is in OOUI.

Since a new version of OOUI will not be pulled through until a week after the next train, we should do the following, in order to avoid T243075#5829744 becoming an issue:

  1. Add selected items to the 'options' config in UsersMW (core)
  2. Add selected items to the 'options' config in MenuTagMW (OOUI)
  3. Remove the lines adding the selected items in TitlesMW and UsersMW, after OOUI is pulled through, since it's now done in the parent (core)

Event Timeline

Change 567166 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[mediawiki/core@master] UsersMultiselectWidget: Add pre-selected items as options

https://gerrit.wikimedia.org/r/567166

Change 567172 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[oojs/ui@master] MenuTagMultiselectWidget: Add pre-selected items as options

https://gerrit.wikimedia.org/r/567172

Change 567173 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[mediawiki/core@master] Remove handling for pre-selected options from multiselect widgets

https://gerrit.wikimedia.org/r/567173

Change 567172 merged by jenkins-bot:
[oojs/ui@master] MenuTagMultiselectWidget: Add pre-selected items as options

https://gerrit.wikimedia.org/r/567172

Change 567166 merged by jenkins-bot:
[mediawiki/core@master] UsersMultiselectWidget: Add pre-selected items as options

https://gerrit.wikimedia.org/r/567166

dom_walden added a subscriber: dom_walden.

Bug in T243075#5829744 no longer occurs Special:Preferences on https://en.wikipedia.beta.wmflabs.org (1.35.0-alpha (74b7a2b) 14:09, 4 February 2020).

Change 570418 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/core@master] Update OOUI to v0.36.4

https://gerrit.wikimedia.org/r/570418

Change 570418 merged by jenkins-bot:
[mediawiki/core@master] Update OOUI to v0.36.4

https://gerrit.wikimedia.org/r/570418

Change 567173 merged by jenkins-bot:
[mediawiki/core@master] Remove handling for pre-selected options from multiselect widgets

https://gerrit.wikimedia.org/r/567173

Jdforrester-WMF closed this task as Resolved.Feb 5 2020, 11:09 PM