Page MenuHomePhabricator

Hewiki: Allow patroller group to edit autopatrol protect level
Closed, ResolvedPublic

Description

In hewiki the user groups permissions are:
autopatroller < patroller < sysop

Page protected with autopatrol level should be editable for autopatroller, patroller and sysop and it looks like recently patroller can't edit pages protected in that level anymore.

Details

Related Gerrit Patches:
operations/mediawiki-config : masterAssign editautopatrolprotected to hewiki patrollers

Event Timeline

eranroz created this task.Sat, Jan 25, 12:05 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSat, Jan 25, 12:05 PM

Probably caused by T230103: Systematize wgRestrictionLevels - hewiki doesn't appear to have been updated

Urbanecm claimed this task.Sat, Jan 25, 1:19 PM
Urbanecm triaged this task as High priority.

On it

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptSat, Jan 25, 1:19 PM
Restricted Application added a subscriber: Dereckson. · View Herald Transcript

Change 567240 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Assign editautopatrolprotected to hewiki patrollers

https://gerrit.wikimedia.org/r/567240

IKhitron added a subscriber: IKhitron.
MBH added a subscriber: MBH.Sun, Jan 26, 1:18 AM
Urbanecm moved this task from Backlog to To deploy on the User-Urbanecm board.Mon, Jan 27, 12:33 PM

Change 567240 merged by jenkins-bot:
[operations/mediawiki-config@master] Assign editautopatrolprotected to hewiki patrollers

https://gerrit.wikimedia.org/r/567240

Mentioned in SAL (#wikimedia-operations) [2020-02-03T12:20:01Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: 6c48af8: Assign editautopatrolprotected to hewiki patrollers (T243665) (duration: 01m 06s)

Urbanecm closed this task as Resolved.Mon, Feb 3, 12:22 PM

Fixed, thanks for your patience.