Page MenuHomePhabricator

Beta: Undefined index: 1x in /srv/mediawiki-staging/php-master/includes/Setup.php on line 186
Closed, ResolvedPublic

Description

There is an error in Beta that is preventing beta-scap-eqiad from running:

RuntimeError: Scap failed!: Call to mwscript eval.php stderr: Notice: Undefined index: 1x in /srv/mediawiki-staging/php-master/includes/Setup.php on line 186

I noticed a couple of changes this morning that look possibly related:

d450288 wgLogoHD and $wgVectorPrintLogo is replaced with wgLogos (2/2) by jdlrobson · 3 hours ago master
5cc2b70 wgLogoHD and $wgVectorPrintLogo is replaced with wgLogos (1/2) by jdlrobson · 13 hours ago

https://gerrit.wikimedia.org/g/operations/mediawiki-config/+/d4502884%5E%21/
https://gerrit.wikimedia.org/g/operations/mediawiki-config/+/5cc2b70%5E%21/

Not clear how that could cause this offhand, but it does seem related.

Adding @Jdlrobson for input.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 5 2020, 3:36 PM
Michael added a subscriber: Michael.Feb 5 2020, 3:37 PM

This'll have been caused by 8cd2e13. Will dig.

Change 570365 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/core@master] Follow-up 8cd2e13: Setup: Check that 1x key has been set in wgLogos before using

https://gerrit.wikimedia.org/r/570365

Change 570378 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[operations/mediawiki-config@master] Set $wgLogos['1x'] (new style access) to $wgLogo (old style access)

https://gerrit.wikimedia.org/r/570378

Change 570365 merged by jenkins-bot:
[mediawiki/core@master] Follow-up 8cd2e13: Setup: Check that 1x key has been set in wgLogos before using

https://gerrit.wikimedia.org/r/570365

Jdforrester-WMF triaged this task as Unbreak Now! priority.
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptFeb 5 2020, 6:24 PM
Krinkle closed this task as Resolved.Feb 5 2020, 6:47 PM
Krinkle added a subscriber: Krinkle.

I pointed this out in code review. Immediate bug fixed, so closing. Will follow up on parent task. I don't think the core compat code now works as intended for existing wikis, nor does it work for new wikis. It only works with the ad-hoc config state we now have in wmf-config, which also looks unintended...

Change 570378 merged by jenkins-bot:
[operations/mediawiki-config@master] Set $wgLogos['1x'] (new style access) to $wgLogo (old style access)

https://gerrit.wikimedia.org/r/570378

abi_ added a subscriber: abi_.Feb 7 2020, 3:58 PM

We were also affected by this during our translatewiki.net update.

Change 570375 had a related patch set uploaded (by Abijeet Patro; owner: Abijeet Patro):
[translatewiki@master] Replace usage of $wgLogoHD with $wgLogos

https://gerrit.wikimedia.org/r/570375

Change 570375 merged by jenkins-bot:
[translatewiki@master] Replace usage of $wgLogoHD with $wgLogos

https://gerrit.wikimedia.org/r/570375