Page MenuHomePhabricator

Migrate GapFinder to the new validator framework
Closed, ResolvedPublic

Description

Migrate the existing checker / suggester code to instead use the new validator framework. We need to add,

  1. WikiParameter validator (insertable but not enforced)
  2. Mediawiki Plural validator (not enforced)

We'll need to update the YAML configuration file located here - https://phabricator.wikimedia.org/diffusion/GTWN/browse/master/groups/

Documentation: https://www.mediawiki.org/wiki/Help:Extension:Translate/Validators
Example patch: https://gerrit.wikimedia.org/r/c/translatewiki/+/549930

Details

Related Gerrit Patches:

Event Timeline

abi_ created this task.Feb 11 2020, 6:23 AM

Change 571419 had a related patch set uploaded (by Abijeet Patro; owner: Abijeet Patro):
[translatewiki@master] Update GapFinder to use the new validator framework

https://gerrit.wikimedia.org/r/571419

abi_ triaged this task as Medium priority.Feb 11 2020, 6:43 AM
abi_ moved this task from Backlog to Configuration changes on the translatewiki.net board.

Change 571419 merged by jenkins-bot:
[translatewiki@master] Update GapFinder to use the new validator framework

https://gerrit.wikimedia.org/r/571419

Zoranzoki21 closed this task as Resolved.Feb 12 2020, 2:56 PM
Zoranzoki21 added a subscriber: Zoranzoki21.

Looks like this task can be closed as resolved.