Page MenuHomePhabricator

Uploading fails with HTTP status 502
Closed, DuplicatePublic

Assigned To
None
Authored By
Raymond
Feb 11 2020, 8:46 AM
Tokens
"Burninate" token, awarded by Cirdan."Like" token, awarded by Smial."Like" token, awarded by Wilhelm_Zimmerling_PAR."Like" token, awarded by Frank_Schulenburg."Burninate" token, awarded by Emha."Pterodactyl" token, awarded by Tsungam."Like" token, awarded by Ralf_Roletschek."Like" token, awarded by C.Suthorn.

Description

Since some weeks I read on dewiki and the German page "Forum" on Wikimedia Commons complains about a very unstable UploadWizard. Users are very frustrated because it is for some of them (not all!) impossible to upload more than 1 image at the same time. And it seems unpredictable under what circumstances the upload of more image fails.

Personally I am uploading via LightRoom which works well, other users using the Commonist do not report any problems.

Today I tried to find the error or at least the symptoms. I can confirm that using Firefox 72.0.2 it is nearly impossible to upload more then 2 images ot once.

Firefox console shows a hint:

Request from - via cp3052.esams.wmnet, ATS/8.0.5
Error: 502, Next Hop Connection Failed at 2020-02-11 08:20:15 GMT

I am not sure if this is the real error of the symptom of another error.

Anyway: Something should happen very soon otherwise we will loose users/photographers.

Related Objects

Event Timeline

Raymond triaged this task as High priority.Feb 11 2020, 8:46 AM

Same symptoms for me, in Firefox. After small amount of testing, I found it fails in the same way in PaleMoon (a fork of an earlier version of Firefox) and works without issue on Chrome, and on MS Edge. all under windows 10; latest versions in every case.

Looks like this was handled in T250103 - if not and this still happens, please reopen.