Page MenuHomePhabricator

Updating interwiki cache adds invalid entries to the cache
Closed, ResolvedPublic

Description

I've tried to update interwiki cache as part of T240771 earlier today, and dumpInterwiki.php created a change that doesn't seem to be right, as it added entries like # NOTE: This file is automatically generated. Do not try to edit it directly.:q.

Nothing obvious seems to be in dumpInterwiki's git log.

Details

Related Gerrit Patches:
mediawiki/extensions/WikimediaMaintenance : masterdumpInterwiki: Respect comments in dblists
mediawiki/extensions/WikimediaMaintenance : wmf/1.35.0-wmf.20dumpInterwiki: Respect comments in dblists

Event Timeline

Urbanecm created this task.Feb 11 2020, 6:48 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 11 2020, 6:48 PM
Urbanecm updated the task description. (Show Details)Feb 11 2020, 6:48 PM

Can you try using scap update-interwiki-cache and see if that renders the same errors? Or is scap using dumpInterwiki.php as well?

(AFAIK the note at the top of https://wikitech.wikimedia.org/wiki/Update_the_interwiki_cache is no longer true and when promted by scap you should use your current gerrit credentials to commit the change; please ask @Reedy as he may know best though)

Can you try using scap update-interwiki-cache and see if that renders the same errors? Or is scap using dumpInterwiki.php as well?

The scap plugin is indeed using that script, see https://github.com/wikimedia/operations-mediawiki-config/blob/master/scap/plugins/updateinterwikicache.py.

(AFAIK the note at the top of https://wikitech.wikimedia.org/wiki/Update_the_interwiki_cache is no longer true and when promted by scap you should use your current gerrit credentials to commit the change; please ask @Reedy as he may know best though)

One's LDAP password works just fine too.

Please add a note what you are looking for when tagging Language-Team. We don't maintain this code.

Change 574399 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/WikimediaMaintenance@master] dumpInterwiki: Respect comments in dblists

https://gerrit.wikimedia.org/r/574399

Urbanecm removed a project: Language-Team.

Please add a note what you are looking for when tagging Language-Team. We don't maintain this code.

Thought you do, or at least know who could help :-). Anyway, I figured out what the issue is: We added comments to dblists, but didn't change dumpInterwiki.php to respect them. Uploaded a fixing patch.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptFeb 24 2020, 10:08 AM

Change 574431 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/WikimediaMaintenance@wmf/1.35.0-wmf.20] dumpInterwiki: Respect comments in dblists

https://gerrit.wikimedia.org/r/574431

Change 574431 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMaintenance@wmf/1.35.0-wmf.20] dumpInterwiki: Respect comments in dblists

https://gerrit.wikimedia.org/r/574431

Mentioned in SAL (#wikimedia-operations) [2020-02-24T12:19:44Z] <ladsgroup@deploy1001> Synchronized php-1.35.0-wmf.20/extensions/WikimediaMaintenance/dumpInterwiki.php: dumpInterwiki: Respect comments in dblists (T244906) (duration: 00m 56s)

Change 574399 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMaintenance@master] dumpInterwiki: Respect comments in dblists

https://gerrit.wikimedia.org/r/574399

Urbanecm closed this task as Resolved.Feb 24 2020, 1:11 PM

Successfully updated production and beta interwiki cache.