Page MenuHomePhabricator

107: Make empty lists list collapsible and collapsed
Closed, ResolvedPublicFeature

Description

Hi. Could you, please, make the bottom part "sites with no changes" collapsible and start it collapsed? Always, or if it has, say, at least five elements, as you wish. It is too long and disturbing most of the time. Thank you.

Event Timeline

IKhitron created this task.Feb 14 2020, 8:07 PM
Restricted Application assigned this task to DannyS712. · View Herald TranscriptFeb 14 2020, 8:07 PM
Restricted Application added a subscriber: DannyS712. · View Herald Transcript
IKhitron changed the subtype of this task from "Task" to "Feature Request".Feb 14 2020, 8:07 PM
Restricted Application added a project: User-DannyS712. · View Herald TranscriptFeb 14 2020, 8:07 PM

Is the just the list of sites with no changes? Its at the bottom, so I didn't think anyone would mind if they have too many sites

Yes. For me, it will look much better. I have 17 sites like these at this moment, for example. And it should be very easy.

DannyS712 renamed this task from Make empty lists list collapsible and collapsed to 107: Make empty lists list collapsible and collapsed.Feb 14 2020, 11:46 PM
IKhitron reopened this task as Open.Feb 15 2020, 2:01 PM

Danny, I think you've closed the wrong task - the bottom list is still opened, and even when you click collapse, it reopens on refresh.

Masumrezarock100 closed this task as Resolved.EditedFeb 15 2020, 4:12 PM
Masumrezarock100 added a subscriber: Masumrezarock100.

That's not an unexpected behavior since GW doesn't track whether people have collapsed the list or not. I'd call this task resolved since the criteria for sign-off has been met. Feel free to open a new task if you'd like a pinning function. I think cookies can be used to track whether a user have collapsed the list. See an example, RevisionSlider extension.
The styling of the collapse link could be made similar to it.


The screenshot of https://meta.wikimedia.org/w/index.php?diff=19810190&oldid=19808405&diffmode=source.

That's not an unexpected behavior since GW doesn't track whether people have collapsed the list or not. I'd call this task resolved since the criteria for sign-off has been met. Feel free to open a new task if you'd like a pinning function. I think cookies can be used to track whether a user have collapsed the list. See an example, RevisionSlider extension.
The styling of the collapse link could be made similar to it.


The screenshot of https://meta.wikimedia.org/w/index.php?diff=19810190&oldid=19808405&diffmode=source.

I do not talk about the pinning function, just mentioned it as a second best. The purpose of this task is go start the last part collapsed. If it will be resolved, there is no need in the pinning function. Please reopdn the task.

Current behavior

The sites with no changes can perfectly be collapsed as seen in the screenshot.After clicking refresh, the collapse state automatically changes to expand.

If I understand correctly, you are saying a collpased list should stay collpased (not auto-expand) even after a refresh? I'd support such change. Maybe cookies can be used to remember the user's preference?

Not at all. It can be good, but it is not a part of this task. All I'm saying that the script should have something like

$('.globalWatch-col').addClass('mw-collapsed');

Not at all. It can be good, but it is not a part of this task. All I'm saying that the script should have something like

$('.globalWatch-col').addClass('mw-collapsed');

The "Sites with no changes" section should be collapsed by default. Is that what you are saying? @DannyS712 can you make a decision whether it should be collpased by default?

Exactly. This was the purpose of this task. This


is too much.

Masumrezarock100 added a comment.EditedFeb 15 2020, 6:01 PM

I have fewer sites to watch. So I don't mind it expanded. Other users might also like it expanded or collpased (depends on the user). If T245348 gets implemented, I believe this problem of yours will be solved.

Sure, but this is much simpiler that T245348.

So, what do you say, @DannyS712?

So, what do you say, @DannyS712?

As I noted in 112, this is the intended behaviour and I don't intend to change is

@Danny, we're talking about different things here. Let me try to explain once again. I do not talk about pinning. I talk about the state when all edits lists will start un-collapsed and only the bottom list will start collapsed, because no one needs it, except for special occasions.

we're talking about different things here. Let me try to explain once again. I do not talk about pinning. I talk about the state when all edits lists will start un-collapsed and only the bottom list will start collapsed, because no one needs it, except for special occasions.

Oh. Let me take a look

we're talking about different things here. Let me try to explain once again. I do not talk about pinning. I talk about the state when all edits lists will start un-collapsed and only the bottom list will start collapsed, because no one needs it, except for special occasions.

Oh. Let me take a look

{{done}}

{{done}}

Unfortunately it did not change anything.

The bottom list of empty sites should be collapsed... is it not?

The bottom list of empty sites should be collapsed... is it not?

No, it isn't.

The bottom list of empty sites should be collapsed... is it not?

No, it isn't.

Are you using the latest (development) version?

Are you using the latest (development) version?

Yes, I do.

Are you using the latest (development) version?

Yes, I do.

What skin, and what site?

What skin, and what site?

Vector. Ruwiki.

Cannot reproduce

Cannot reproduce

Firefox?

I don't have firefox installed, sorry

I don't have firefox installed, sorry

Then Chrome?

I tried with Chrome, and it works for me

I tried with Chrome, and it works for me

Weird. Actually, I never could able to combine $.makeCollapsible() with .mw-collapsed. Only .mw-collapsible.
And I do not see .mw-collapsed:

<div class="globalWatch-emptySites mw-collapsible mw-made-collapsible"><span class="mw-collapsible-toggle mw-collapsible-toggle-default" role="button" tabindex="0" aria-expanded="true"><a class="mw-collapsible-text">скрыть</a></span><div class="mw-collapsible-content"><div class="globalWatch-col"><ul><li class="globalWatch-emptyWatchlist"><a href="https://commons.wikimedia.org/wiki/Special:Watchlist">commons.wikimedia</a> (<a href="https://commons.wikimedia.org/wiki/Special:EditWatchlist">Изменение списка наблюдения</a>)</li><!--More wikis--></ul></div></div></div>

Found the problem, @DannyS712. Forget about it.