Page MenuHomePhabricator

Further compress the de.wikipedia.org logo on desktop to save energy
Closed, InvalidPublic

Description

Sustainability activist Niklas Jordan [1] was quoted in a German newspaper [2] with the claim that scaling down the Wikipedia logo on desktop would lead to a significant reduction in Wikipedia's carbon footprint without any loss in image quality.

Is there any substance to this claim?

[1] Niklas Jordan's on Twitter
[2] "Pfuschen im ganz großen Stil", Frankfurter Allgemeine Zeitung, 30 December 2019

Event Timeline

Gnom1 created this task.Feb 16 2020, 3:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 16 2020, 3:54 PM
Masumrezarock100 added a subscriber: Masumrezarock100.

(Not sure if it's the correct tag. Feel free to remove it if it is not!)

RhinosF1 added a subscriber: RhinosF1.EditedFeb 16 2020, 4:45 PM

Scaling down an image can likely be done as a Wikimedia-Site-requests.

Not sure if consensus will be needed though.

Not sure if consensus will be needed though.

I believe so. Community consensus is needed and WMF approval.

Not sure if consensus will be needed though.

I believe so. Community consensus is needed and WMF approval.

I’m going to stall this and tag community consensus needed. Meta Wiki is probably the best venue.

Not sure exactly who is best to get a WMF sign off from though.

RhinosF1 changed the task status from Open to Stalled.Feb 16 2020, 4:50 PM
RhinosF1 moved this task from Unsorted to All WMF wikis on the Community-consensus-needed board.

Moving as only affects ‘Wikipedia’s’ in this request.

revi added a subscriber: revi.Feb 16 2020, 5:00 PM

IMO burden of proof is on the one who makes the claim, not us. /shrug

revi removed a subscriber: revi.Feb 16 2020, 5:00 PM
Aklapper closed this task as Invalid.Feb 16 2020, 5:23 PM

I don't see anything in that German newspaper article about "scaling down", I only see one vague sentence about lossless compression...

Is there any substance to this claim?

Further details would have been nice. :) Watching the video of that mentioned talk, this seems to be about https://de.wikipedia.org/static/images/project-logos/dewiki-2x.png (a HiDPI logo) which is 46276 bytes, and the statement is that ImageOptim (which is only available for Mac) would change the size to 20134 bytes. (For the records, the non-HiDPI logo at https://de.wikipedia.org/static/images/project-logos/dewiki.png is only 10236 bytes.)
People have been using pngrewrite and optipng for Wikimedia logos for 15 years (random example link).
We also recommend using optipng in e.g. https://wikitech.wikimedia.org/wiki/Wikimedia_site_requests#Change_the_logo_of_a_Wikimedia_wiki

Using optipng on https://de.wikipedia.org/static/images/project-logos/dewiki-2x.png :

$:ac\> optipng -o7 dewiki-2x.png 
** Processing: dewiki-2x.png
270x310 pixels, 4x8 bits/pixel, RGB+alpha
Input IDAT size = 46145 bytes
Input file size = 46276 bytes

Trying:
  zc = 9  zm = 8  zs = 0  f = 0		IDAT size = 46145
                               
dewiki-2x.png is already optimized.

If you find logos which are not optimized, feel free to create dedicated tasks.
If you find free software which allows further lossless optimization, feel free to share your knowledge.

Closing this task as invalid, as I do not see anything actionable currently.

Dcljr added a subscriber: Dcljr.EditedFeb 16 2020, 5:36 PM

(composed before Aklapper's comment above)

The article couches the potential energy savings in completely arbitrary units ("you could fly back and forth a few times between Berlin and London", according to Google Translate). It is not at all clear whether this represents a significant savings compared to the human and computing resources needed to make the change (e.g., presumably, all cached versions of WP pages — both on Wikimedia servers and locally on countless computers around the world — would need to be updated after the change).

If we can further compress the logo with no loss of quality, I guess it's worth discussing (at Meta, or wherever), but not necessarily for the reasons being claimed in the article.

Krinkle renamed this task from Scale down the Wikipedia logo on desktop to save energy to Scale down the de.wikipedia.org logo on desktop to save energy .Feb 16 2020, 6:20 PM
Gnom1 added a comment.Mar 9 2020, 9:55 PM

After speaking with @Aklapper, I asked Niklas Jordan for 'his' scaled-down version of the file and here it is: Wikipedia-logo-v2-de optimised.png

I am unable to verify whether it has the desired properties, so I would be happy for any pointers on how to move this discussion in the right direction.

After speaking with @Aklapper, I asked Niklas Jordan for 'his' scaled-down version of the file and here it is: Wikipedia-logo-v2-de optimised.png

I am unable to verify whether it has the desired properties, so I would be happy for any pointers on how to move this discussion in the right direction.

I suggest reopening this once at least deWp have agreed to it and we've assessed how we can effectively do this for all wikis and spoke to them. If we should be doing this and there's a value, it should be agreed on by everyone,

Aklapper renamed this task from Scale down the de.wikipedia.org logo on desktop to save energy to Further compress the de.wikipedia.org logo on desktop to save energy.Mar 10 2020, 1:49 AM
Aklapper reopened this task as Open.
Reedy added a subscriber: Reedy.Mar 10 2020, 2:10 AM

After speaking with @Aklapper, I asked Niklas Jordan for 'his' scaled-down version of the file and here it is: Wikipedia-logo-v2-de optimised.png

I am unable to verify whether it has the desired properties, so I would be happy for any pointers on how to move this discussion in the right direction.

Can you find out how he created it? "scaled down" in what sense? ie what tool(s) were run on it to get to what it is now, and for completeness, what file he started with?

Hi @Reedy, he started with https://de.wikipedia.org/static/images/project-logos/dewiki-2x.png and used a tool called ImageOptim. Does that answer your question?

@RhinosF1, can you name a reason why a community member might be opposed to using a version of the file that is optimised? I am having trouble understanding why we would need community consensus for such a trivial change, but maybe I am overlooking something.

Hi @Reedy, he started with https://de.wikipedia.org/static/images/project-logos/dewiki-2x.png and used a tool called ImageOptim. Does that answer your question?

Yeah, that helps. So we can document and reproduce it :). Otherwise it's a case of "that's nice" and we can't do any more. And if it's deemed an acceptable improvement (ie no negative visual changes) we could look at optimising at other images

Removes bloated metadata. Saves disk space & bandwidth by compressing images without losing quality.
Removes invisible junk: private EXIF meta­data from digital cameras, embedded thumbnails, comments, and unnecessary color profiles.
Seamlessly combines all the best image optimization tools: MozJPEG, pngquant, Pngcrush, 7zip, SVGO and Google Zopfli.

I think "community" consensus isn't needed, but certainly consensus that we want to go ahead with optimising with these images in this way/with this tool

$ ls -al dewiki-2x*
-rw-r--r--@ 1 reedy  staff  46276 26 Mar 22:43 dewiki-2x-orig.png
-rw-r--r--@ 1 reedy  staff  43576 26 Mar 22:44 dewiki-2x.png

Orig:

If we turn everything up, and set things to "insane", enable all optimisers...

5.8% saving, 43,576 bytes

Needs someone with a much keener eye to look at it

Further details would have been nice. :) Watching the video of that mentioned talk, this seems to be about https://de.wikipedia.org/static/images/project-logos/dewiki-2x.png (a HiDPI logo) which is 46276 bytes, and the statement is that ImageOptim (which is only available for Mac) would change the size to 20134 bytes. (For the records, the non-HiDPI logo at https://de.wikipedia.org/static/images/project-logos/dewiki.png is only 10236 bytes.)

I don't see anywhere near the same sort of savings (with no lossy minification enabled) quoted at basically 50%+...

Not tried https://imageoptim.com/api (paid)

Aklapper triaged this task as Lowest priority.Mar 27 2020, 10:09 AM
tomasz added a subscriber: tomasz.EditedApr 25 2020, 11:58 PM

Hi @Reedy, he started with https://de.wikipedia.org/static/images/project-logos/dewiki-2x.png and used a tool called ImageOptim. Does that answer your question?

I have been using ImageOptim for the past few years while creating new Wikipedia logos (and updating existing ones) and have never noticed results as big as those claimed here. In fact, for this particular German Wikipedia logo I'm seeing the exact same possible percentage reduction as Reedy — 5.8%.

We/I have been taking extra care since about 2012 (I think?) in only ever uploading optimised PNG logos, not only for Wikipedia but also for the other Wikimedia projects and have therefore saved a lot of transcontinental flights' worth of Co2e, to use this arbitrary measure. Nonetheless, if there is a compression method that is scalable and easily reproducible that would help us save bandwith (not only to reduce the resultant carbon footprint...) I for one would be very eager to learn it and apply for future logos.

Aklapper closed this task as Invalid.Apr 26 2020, 9:15 AM

As nobody can reproduce an alleged 56% size reduction but only 6%, I am going to close this task as it states non-actionable things noone else can reproduce.
For future reference, more actionable/complete tickets which don't lack information how to reproduce something would be welcome.