Page MenuHomePhabricator

Can't delete 10th duplicate child of Queen Victoria
Closed, ResolvedPublic

Description

https://www.wikidata.org/wiki/Q9439 recently got a 10th child by duplicating the https://www.wikidata.org/wiki/Property:P40 child entry of Princess Louise, Duchess of Argyll.
When trying to remove this superflous entry I got an error message.

My test case for the Wikidata SimpleGraph module https://github.com/BITPlan/com.bitplan.simplegraph/blob/master/simplegraph-wikidata/src/test/java/com/bitplan/simplegraph/wikidata/TestWikiDataSystem.java#L155 fails since it assumes the historical fact that Queen Victoria had 9 children.

Related Objects

Mentioned Here
P40 silly nagios

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 17 2020, 2:55 PM
Aklapper changed the task status from Open to Stalled.Feb 17 2020, 3:24 PM

Hi @Seppl2013, thanks for taking the time to report this. Please follow https://www.mediawiki.org/wiki/How_to_report_a_bug and provide 1) clear steps to reproduce, 2) what you expect and where, 3) what happens instead.

Seppl2013 added a comment.EditedFeb 18 2020, 9:10 AM


has a duplicate child https://www.wikidata.org/wiki/Property:P40 entry Duchess of Argyle https://www.wikidata.org/wiki/Q161167 which I could not remove.

The expected behavior should be:

  • it should not be possible to add two entries https://www.wikidata.org/wiki/Property:P40 for the same child
  • if two duplicate entries where entered it should be possible to remove one of them to fix the situatio
Seppl2013 added a comment.EditedFeb 18 2020, 9:25 AM

@Samwilson thanks a lot - i am reran my unit tests for SimpleGraph on travis now - locally the result was. o.k. again and https://travis-ci.org/BITPlan/com.bitplan.simplegraph/builds/651888723 shows the travis result is also fixed.

What can be done about the systematic issue of uniqueness constraints? Is this the right place to report such issues or does wikidata have a different place to do so?

I'm not sure. I have noticed sometimes that there can be a lag sometimes with constraint analysis, especially with things like item merges. Could that be what you're seeing? i.e. is it reliably reproducible?

Seppl2013 added a comment.EditedFeb 18 2020, 9:32 AM

I don't even know whether there is a constraint or it is just missing. The visualization of the data does not indicate this. I wouldn't want to temper with the original data to check the issue and my copy of Wikidata does not have the current tools - it is from January 2018.

What can be done about the systematic issue of uniqueness constraints? Is this the right place to report such issues or does wikidata have a different place to do so?

See https://www.wikidata.org/wiki/Wikidata:Contact_the_development_team for Wikidata places.

Hi @Seppl2013, if "it should not be possible to add two entries for the same child", then feel free to edit this task by following https://www.mediawiki.org/wiki/How_to_report_a_bug . The current task description lacks 1) clear steps to reproduce, 2) expected outcome, 3) actual outcome, including exact error messages.
It is still unclear to me if this task was or is about something wrong in Wikidata. Or about fixing code in a third-party module. Or something else.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results.

You can edit the task description by clicking Edit Task. Thanks!

To reproduce this you need:

  • a copy of wikidata including the tools (which I have but is outdated and does not have the tools)
  • a person like Queen Victoria with some children connected via P40
  • add two children with the same qid (should not be possible)
  • if two children exist delete one of them (should be possible)

I do not have the error message that was shown to me when i tried to delete the child but there was one which did not explain why the remove was not possible it simply said something like "failed". Unfortunately i did not make a screenshot.

Aklapper changed the task status from Stalled to Open.Feb 18 2020, 9:49 AM
Aklapper added a project: Wikidata.

@Seppl2013: Thanks. Please edit the task summary and task description to include clear steps to reproduce, expected outcome, and actual outcome.

The way Wikidata works, it should be possible. It can lead to a constraint violation, but Wikidata/Wikibase itself almost constraints nothing (only constraint is datatype constraints). If you want to prevent a duplicate entry for a property with a unique value constraint you should make a gadget for that.

I do not have the error message that was shown to me when i tried to delete the child but there was one which did not explain why the remove was not possible it simply said something like "failed". Unfortunately i did not make a screenshot.

That could very well be possible. The Wikidata devs are working on improving error messages.

Lydia_Pintscher closed this task as Resolved.Feb 18 2020, 7:21 PM
Lydia_Pintscher claimed this task.
Lydia_Pintscher added a subscriber: Lydia_Pintscher.

Thanks for the report. As @Mbch331 said the ability to add duplicate statements is intentional as you for example might later differentiate them with a qualifier. Imagine someone being elected into a government position twice. Then you'd add them twice and add qualifiers for their two different times in office.

As we don't know which error message was shown and can't reproduce it I fear there is nothing we can do further here. Sorry.