Page MenuHomePhabricator

Reply link does not appear on the first time loading DiscussionTools (on hu and ar wiki)
Closed, InvalidPublic

Description

Noticed this for ar wiki and hu wiki so far. When I enabled DiscussionTools with the query string parameter
?dtenable=1 on a talk page on these wikis I didn't see any Reply link. After refreshing the page it appeared.

Screenshot:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 18 2020, 11:23 PM
Ryasmeen renamed this task from Reply link does not appear on the first time loading DiscussionTools to Reply link does not appear on the first time loading DiscussionTools (on hu and ar wiki) .Feb 18 2020, 11:24 PM
Ryasmeen updated the task description. (Show Details)Feb 18 2020, 11:33 PM
JTannerWMF added a project: Editing QA.
JTannerWMF added a subscriber: JTannerWMF.

Hey @Ryasmeen, @ppelberg and I are on a call now trying to reproduce and we aren't able to. Can you check if you're still running into this issue? Can you also add to the ticket which browser you used when this error occurred?

Hey @Ryasmeen, @ppelberg and I are on a call now trying to reproduce and we aren't able to. Can you check if you're still running into this issue? Can you also add to the ticket which browser you used when this error occurred?

Hi @JTannerWMF, yeah this one is a bit hard to reproduce, I got this error on Chrome and only when I enabled DiscussionTools for the first time. Couldn't reproduce it anymore on the next few attempts. So maybe try to use an account that never enabled DiscussionTools on those wiki before.

ppelberg closed this task as Invalid.Feb 21 2020, 4:53 PM

Hey @Ryasmeen, @ppelberg and I are on a call now trying to reproduce and we aren't able to. Can you check if you're still running into this issue? Can you also add to the ticket which browser you used when this error occurred?

...So maybe try to use an account that never enabled DiscussionTools on those wiki before.

Good news (I think?): I tried the above using Chrome and on an account that never enabled DiscussionTools [1] and I was not able to reproduce the issue. Read: Reply links appeared as I expected them to on first load.

Considering the above, I'm going to close this as invalid with the following assumption in mind: checking whether the reply links appear as we expect them to will be part of our routine QA.

Meaning: if this is still an issue, we have a plan in place to detect it.


  1. https://fr.wikipedia.org/wiki/Discussion:Donald_Trump?dtenable=1