Page MenuHomePhabricator

Remove duplicate Vue ResourceLoader module from Wikibase
Closed, DuplicatePublic

Description

WikibaseLib has shipped Vue.js v2.6.11 as the vue2 ResourceLoader module for a while. More recently, the same version was also added to MediaWiki core as vue (I2ab1f6364a). We should use that module and remove the WikibaseLib version to reduce duplicated code shipped to users.

Event Timeline

Change 578354 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/WikibaseLexeme@master] Use vue ResourceLoader module from MediaWiki core

https://gerrit.wikimedia.org/r/578354