Page MenuHomePhabricator

Un-checking "Watch this page" boxes and hitting 'save' deletes previous revisions.
Open, Stalled, Needs TriagePublic

Description

Three separate users complained that I was reverting their pages. I could not understand what was happening and asked usernamekiran for help. (Full discussion here: https://en.wikipedia.org/wiki/User_talk:Usernamekiran) Nothing was resolved.

Finally I went to un-check myself from Bbb23 talk page and HE complained I had reverted his page! As best as I can explain it:
"Each time I left a message or followed a page I checked the "Watch this page" box; when the subject changed or I finished I went back to the page to un-check the box and hit "Publish changes"!!! When I did this today on your talk page Bbb23 a message flashed "your revision was saved" as usual, but it looks like the program is revising text instead of just un-watching the page. It explains all this balagan (mess). Can something be done about it? Cheers! Shir-El too 17:29, 20 February 2020"

Since then I've learned to use the 'star,' but it still seems like a glitch.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 22 2020, 3:06 PM

What next? ~~~~

Masumrezarock100 closed this task as Invalid.Feb 22 2020, 3:35 PM
Masumrezarock100 added a subscriber: Masumrezarock100.

Hi, and welcome to Phabricator. Unfortunately your task lacks necessary information for developers to work on it. Please follow the instructions at https://www.mediawiki.org/wiki/How_to_report_a_bug and clearly explain how to reproduce this issue. Thanks!

Aklapper reopened this task as Stalled.Feb 22 2020, 3:37 PM

@Shir-El_too: Hi and welcome! Please also test if this happens when disabling all and any user scripts or gadgets, plus explain which website this is about, plus provide clear full links and steps to reproduce. See the link that masumrezarock100 provided. Thanks a lot! :)

@Aklapper : Thank you. As far as I know I don't have any "user scripts or gadgets." These events occurred on Wikipedia articles and talk pages. I'm not sure what more information you need or I can give.

When I wanted to stop receiving updates from a particular page I would press "Edit" on that page, go to the bottom of the edit section, uncheck the "Watch this page" box and press "Submit Changes." [BTW I've been doing this for as long as I've been editing WP.]

Unfortunately, each time I did this the program REVERTED the last edit that had been made on that page, no matter by whom, and crediting me as the cause. It is repeatable as it has already happened 4 or 5 times.

Hope this helps!

These events occurred on Wikipedia articles and talk pages.

There are more than 300 Wikipedias and each one can have a different configuration. :) @Shir-El_too: It would be great if you could check the link provided by Masumrezarock100 and provide a clear list of steps to reproduce, step by step, as a list, which leaves no room for interpretation. Thanks!

@Aklapper "300 Wikipedias"???? I only use one: en/wikipedia.org! I have no idea what you are talking about, or asking me to do. I am trying to report what appears to me to be a glitch in the programing - and feel like I'm being asked to learn programing-ese to report it. I am not a technical person and don't pretend to be. I AM getting very frustrated, though, because all the cases in point - the links to what happened - are included in the original conversation, and I sent the link to that. Or is WIKIMEDIA becoming tangled up in/by its own administrivia? I hope not. Whatever the outcome, thank you for your reply.

So in a nutshell @Shir-El_too is complaining that he is not getting edit-conflict warnings when he saves the page (in the process of trying to make a null edit in order to unwatch a page). As a result, his edit accidentally reverts someone else.

Unless @Shir-El_too was editing a page from a perma-link, this does indeed sound like a bug.

@Aklapper "300 Wikipedias"???? I only use one: en/wikipedia.org! I have no idea what you are talking about, or asking me to do. I am trying to report what appears to me to be a glitch in the programing - and feel like I'm being asked to learn programing-ese to report it. I am not a technical person and don't pretend to be. I AM getting very frustrated, though, because all the cases in point - the links to what happened - are included in the original conversation, and I sent the link to that. Or is WIKIMEDIA becoming tangled up in/by its own administrivia? I hope not. Whatever the outcome, thank you for your reply.

They're just asking you what you did, what you expected to happen, and what happened instead. Along with which site it was on (Is it English Wikipedia? Is it Swedish Wiktionary? something else?). I don't think that's an unreasonable request, your original post was pretty convoluted and difficult to follow. Don't take it personally, its just that we get a lot of these tickets, and if we have to spend half an hour trying to figure out what each person actually meant, we wouldn't have any time to fix the bugs.

You should at least include

  • Step by step instructions on what you are doing. (Otherwise we might guess, and guess wrong, and then not be able to see the problem)
  • diff links to the edits in question where you accidentally reverted someone
  • Which wiki-editor are you using, and if you are using any user-scripts/gadgets that adjust the edit box or could be causing this issue.
Restricted Application added a project: Growth-Team. · View Herald TranscriptFeb 24 2020, 11:45 AM

@Bawolff CORRECT! Hallelujah! I'm a "she" and don't know what a 'perma-link' is. As far as I know I'm using the oldest version of en/wikipedia there is, the one I started with in 2007. No devices or gadgets, just a PC. If you can tell me where to look I'll dig up the WP version info you want. Many Thanks!

@Bawolff CORRECT! Hallelujah! I'm a "she" and don't know what a 'perma-link' is. As far as I know I'm using the oldest version of en/wikipedia there is, the one I started with in 2007. No devices or gadgets, just a PC. If you can tell me where to look I'll dig up the WP version info you want. Many Thanks!

I just mean, if you were editing an "old version" (e.g. Like what you would get if you went to the history page) or a "diff", that might explain the situation, as you would be editing a different version than the current one, so if you saved, it would make the old version be current, reverting to that revision. That's why it would help to get a step by step guide to what you did, so we could rule out the possibility that you clicked on a link to an old version of an article and clicked edit on that.

@Bawolff And thank you for the explanations, I really, REALLY appreciate them! To answer your questions:

*I clicked on "edit" on a page and clicked on the "Watch this page" box.
*Since I was already 'watching' it, I expected the box to be cleared - which it was.
*I then hit "Publish changes" to close the edit and execute the command.
*A message flashed for a moment "Your revision has been saved" (I only spotted this the last time it happened, on Bbb23's talk page).
Result: the last revision on the page was removed, regardless of who made it.

This happened at least four time. These are the links from the original discussion: quote

  1. User talk:Doc James: Difference between revisions

Revision as of 07:39, 16 February 2020 (edit) (undo)
Shir-El too (talk | contribs)
'''[https://en.wikipedia.org/w/index.php?title=User_talk:Doc_James&type=revision&diff=941043474&oldid=941007794&diffmode=source Here]''' (Diff #1)

  1. This seems to be where the trouble started [https://en.wikipedia.org/w/index.php?title=Wikipedia_talk:WikiProject_Medicine&diff=940225727&oldid=940218432 first?] (Diff #2)

(The message '''above''' User talk:WhatamIdoing [https://en.wikipedia.org/wiki/User_talk:WhatamIdoing#Two_replies...] is: '''''Enabling Visual Editor Citation Tool for Twi Wikipedia''''' - Could this have anything to do with it?)

  1. and here's another: Wikipedia talk:WikiProject Medicine: Difference between revisions [https://en.wikipedia.org/w/index.php?title=Wikipedia_talk:WikiProject_Medicine&diff=prev&oldid=941112429] (Diff #3)

unquote
At first I could not find them in my "Contributions" list, which added to the confusion, but user Bbb23 found them and so did I, as well as adding the "Diff #". But the final clue came when Bbb23 wrote: "... can you please explain why you made [https://en.wikipedia.org/w/index.php?title=User_talk:Bbb23&diff=941723099&oldid=941722519 this refactoring edit] on my Talk page?"

I don't know which "wiki-editor" I'm using. Sorry.

@Aklapper Next time you might ask which LANGUAGE someone is using instead of throwing "300 Wikipedias" at them. Cheers!

@Bawolff No. Again, they were all current pages as far as I know. Cheers!

@Bawolff BTW did anything come of this? Cheers!

Checked the several possible scenarios for

  • editing conflicts
  • incorrectly attributing/processing an empty edit
  • watch/un-watch functionality made via the "Watch this page" check box in the source editor/Visual editor

*I clicked on "edit" on a page and clicked on the "Watch this page" box.
*Since I was already 'watching' it, I expected the box to be cleared - which it was.

For a logged-in user there should be 'Edit source' not just 'Edit'

The 'Publish' button is active even if no edit is made and can be clicked without making any changes to a page (to proceed with checking or un-checking the "Watch this page" box and saving it). Probably some improvement should be done there to make "Publish" button behave as in Visual Editor.

As per @Bawolff comment - https://phabricator.wikimedia.org/T245918#5912963 - the only "reverting" of previous edits would happen if an old revision was edited. In all edit conflict scenarios and old revision editing, there is clear warning message(s) to users informing them of possible implications and of what to do next.

For a logged-in user there should be 'Edit source' not just 'Edit'

That's based on Preferences setting