Page MenuHomePhabricator

Wikimedia Commons "Upload a new version of this file" link uploaded a new version but did not display it
Closed, DeclinedPublic

Description

  1. Go to https://commons.wikimedia.org/wiki/File:Electricity_savings_from_utility_assisted_building_upgrades.png with Chrome version 80.0.3987.122 (Official Build) (64-bit);
  2. Make sure you are logged in;
  3. Scroll down to the "File history" section;
  4. Click the "Upload a new version of this file" link;
  5. Scroll down to "Source file" section;
  6. Click "Choose file" button;
  7. Select "Electricity_savings_from_utility_assisted_building_upgrades.png" from local drive;
  8. Observe that file is correctly previewed in "Source file" section;
  9. In the "File description" section in the "File changes:" box enter "Simplified title and Y-axis labels";
  10. In the "Upload options" section click the "?" icon after "Ignore any warnings";
  11. Read help information and decide to ignore warnings because this is a technical change to the image file;
  12. Check the "Ignore warnings" box;
  13. Click "Upload file" button;
  14. Return to https://commons.wikimedia.org/wiki/File:Electricity_savings_from_utility_assisted_building_upgrades.png ;
  15. Observe that the updated version has been listed in the "File history" section but the new version's Thumbnail has not been updated.
  16. Open a Wikipedia article for editing and link to this image file;
  17. Observe that the Wikipedia article incorrectly displays the old version of the image file;
  18. Reproduce steps 1 through 11;
  19. Scroll down and read this error message: "Upload error The upload is an exact duplicate of the current version of File:Electricity savings from utility assisted building upgrades.png."

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 25 2020, 1:25 AM
Kizule moved this task from Incoming to Uploading on the Commons board.Feb 25 2020, 3:33 AM

Looks like a caching issue. Have you tried to purge the page's cache using action=purge?

I had tried action=purge but it did not resolve the problem

Aklapper changed the task status from Open to Stalled.Feb 28 2020, 11:11 AM

I cannot now reproduce the problem.

I am now using the same browser as before and going directly to https://commons.wikimedia.org/wiki/File:Electricity_savings_from_utility_assisted_building_upgrades.png . I now observe the correct thumbnail for the current revision.
When I now open a Wikipedia article for editing and link to this image file the preview of the article correctly displays the current version of the image.

Aklapper closed this task as Declined.Feb 29 2020, 2:51 PM

Closing as declined as nobody can reproduce...

Closing as declined as nobody can reproduce...

I think it's more like "invalid" than "declined". /shrug