Page MenuHomePhabricator

Fatal Error: Call to a member function getFullUrl() on null
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  1. On a wiki that does not use $wgConf
  2. Go to Special:Investigate
  3. Input at least one known user on the current wiki
  4. Click Submit

Actual Results:

[e30f0a5a41fa9cfd46fff725] /index.php?title=Special:Investigate/Preliminary_Check&token=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJleHAiOjE1ODI3NTAxNTMsImRhdGEiOiI4UWxjYXlxNDdqWGZFM1dEUVA4NXBPNHBIQ21qIn0.GeqJcF_tiZ_yC0kyQuAK7ai1KP1NchTMIaisRIRPYBM Error from line 147 of /var/www/html/extensions/CheckUser/src/PreliminaryCheckPager.php: Call to a member function getFullUrl() on null

Backtrace:

#0 /var/www/html/includes/pager/TablePager.php(197): MediaWiki\CheckUser\PreliminaryCheckPager->formatValue(string, string)
#1 /var/www/html/includes/pager/IndexPager.php(585): TablePager->formatRow(stdClass)
#2 /var/www/html/includes/pager/TablePager.php(106): IndexPager->getBody()
#3 /var/www/html/extensions/CheckUser/src/SpecialInvestigate.php(218): TablePager->getFullOutput()
#4 /var/www/html/extensions/CheckUser/src/SpecialInvestigate.php(86): MediaWiki\CheckUser\SpecialInvestigate->addTabContent(string)
#5 /var/www/html/includes/specialpage/SpecialPage.php(575): MediaWiki\CheckUser\SpecialInvestigate->execute(string)
#6 /var/www/html/includes/specialpage/SpecialPageFactory.php(621): SpecialPage->run(string)
#7 /var/www/html/includes/MediaWiki.php(298): MediaWiki\SpecialPage\SpecialPageFactory->executePath(Title, RequestContext)
#8 /var/www/html/includes/MediaWiki.php(971): MediaWiki->performRequest()
#9 /var/www/html/includes/MediaWiki.php(534): MediaWiki->main()
#10 /var/www/html/index.php(47): MediaWiki->run()
#11 {main}

Expected Results:
A table of results.

Event Timeline

dbarratt created this task.Feb 25 2020, 8:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 25 2020, 8:54 PM

Actually most wikis don't (and need not) use $wgConf. These wikis also don't need the "wiki" field completely.

Change 590496 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/extensions/CheckUser@master] CheckUser: Handle wikis that are not in shared configuration

https://gerrit.wikimedia.org/r/590496

Ammarpad claimed this task.Apr 30 2020, 2:44 PM
Ammarpad added a subscriber: Tchanders.

Change 590496 merged by jenkins-bot:
[mediawiki/extensions/CheckUser@master] CheckUser: Handle wikis that are not in shared configuration

https://gerrit.wikimedia.org/r/590496

dom_walden added a subscriber: dom_walden.

Cannot reproduce on my local docker environment: MediaWiki 1.35.0-alpha (96866bf) 09:42, 4 May 2020; CheckUser 2.5 (7c1af95) 07:14, 4 May 2020

For wikis without CentralAuth, the Preliminary Investigate tab does not have the "Wiki" column, looks like:

For wikis with CentralAuth, looks like it did previously:

Tchanders closed this task as Resolved.May 5 2020, 2:57 PM

Thanks @Ammarpad