Page MenuHomePhabricator

Template namespace no longer support subpages in some Wikis
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

Go to any template subpages in selected wikis, and it no longer show the "breadcrumb" navigation below the title.
Also, {{SUBPAGENAME}} gives the full title, not subpage name.

Obviously I have not made an exhaustive search, but so far i have found the following wikis to fail:

Wikisource (all so far)
Wikibooks (es:, fr:, it: and ca:, but not in en:)

And it seems to be working fine in

Wikipedia, Commons, Wikispecies, Wikivoyage, Wikiquote, Wikiversity, Meta, Mediawiki.... (all languages i've checked)

It seems to be related to the new Mediawiki version implemented.

It causes some templates to stop working (e.g. the ones using {{SUBPAGENAME}} )

Event Timeline

Restricted Application added subscribers: Liuxinyu970226, Aklapper. · View Herald TranscriptFeb 26 2020, 11:42 AM

@MarcoAurelio I'm not sure that this is for Wikimedia-Site-requests.

I'm not sure either but I think Wikimedia-General-or-Unknown might be too vague. Feel free to change the tags if you think there's a more appropriate one.

[urbanecm@mwmaint1002 ~]$ mwscript shell.php metawiki
Psy Shell v0.9.12 (PHP 7.2.26-1+0~20191218.33+debian9~1.gbpb5a340+wmf1 — cli) by Justin Hileman
>>> $wgNamespacesWithSubpages[NS_TEMPLATE]
=> true
>>>

config appears to be correct.

cnr at meta nor testwiki. Can anyone reproduce this?

Ninovolador added a comment.EditedFeb 26 2020, 2:06 PM

@Urbanecm Can you do the same check with the wikis I mentioned in the original post? eswikisource, enwikisource, eswikibooks for example.
The bug isn't currently affecting Meta...

Example failue URL: https://fr.wikibooks.org/wiki/Mod%C3%A8le:M%C3%A9ta_palette_de_navigation/Documentation/Exemple_5

Config has NS_TEMPLATE on by default, not overridden for wikibooks (though it does enable it for NS_MAIN, which is fine, and disable it for NS_MEDIAWIKI, which is rather bizzare), and not over-ridden for frwikibooks.

Not sure where in config it's getting mis-set.

Eyeballing cat wmf-config/config-cache/conf-production-*.json | jq '.wgNamespacesWithSubpages."8"', about half of wikis have it set to false,

Picking German, NS_TEMPLATE should be false for Wikipedia and Wikiversity and true otherwise, but is instead false on Wikibooks and Wikisource as well.

Change 576483 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[mediawiki/core@master] SiteConfiguration: Optimise getSetting() internals for getAll()

https://gerrit.wikimedia.org/r/576483

Change 576483 merged by jenkins-bot:
[mediawiki/core@master] SiteConfiguration: Optimise getSetting() internals for getAll()

https://gerrit.wikimedia.org/r/576483

Change 576864 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[mediawiki/core@wmf/1.35.0-wmf.22] SiteConfiguration: Optimise getSetting() internals for getAll()

https://gerrit.wikimedia.org/r/576864

Change 576864 merged by jenkins-bot:
[mediawiki/core@wmf/1.35.0-wmf.22] SiteConfiguration: Optimise getSetting() internals for getAll()

https://gerrit.wikimedia.org/r/576864

matmarex closed this task as Resolved.Mar 5 2020, 10:03 AM
matmarex assigned this task to Krinkle.

This seems to be resolved by the subtask. The page https://fr.wikibooks.org/wiki/Modèle:Méta_palette_de_navigation/Documentation/Exemple_5 now has breadcrumbs. mw.config.get( 'wgVisualEditorConfig' ).namespacesWithSubpages also returns the expected value, matching the configuration (e.g. namespace 10 "Template"/"Modèle" has subpages).