Page MenuHomePhabricator

Do not add "user-blocked-indef" css to links to partially blocked users.
Closed, InvalidPublic

Description

Existing gadgets use "user-blocked-indef" class to identify sitewide blocked users. This css-class became unusable after it's applied also to partially blocked users.

Event Timeline

AS created this task.Mar 1 2020, 12:22 PM
Restricted Application added subscribers: Base, Aklapper. · View Herald TranscriptMar 1 2020, 12:22 PM
ARamirez_WMF renamed this task from Do not add "user-blocked-indef" css to links to partially blocked users. to Do not add "user-blocked-indef" css to links to partially blocked users. [4 HOURS].Apr 8 2020, 4:36 PM
ARamirez_WMF renamed this task from Do not add "user-blocked-indef" css to links to partially blocked users. [4 HOURS] to Do not add "user-blocked-indef" css to links to partially blocked users. .
aezell added a subscriber: aezell.Apr 8 2020, 4:39 PM

Thanks for this report @AS. We aren't aware of that CSS class actually existing in the code.

There are a few pieces of info that might let us help more:

  1. What page are you looking at where this is broken for you?
  2. What are some of the gadgets that you are having this problem with?
  3. What skin are you using?
  4. Could you give us a step-by-step description of what happens?

With some of these details, we can take a closer look and see how we can help.

AS closed this task as Invalid.Apr 8 2020, 8:07 PM

Hi @aezell! You are right, the class is actually added by a gadget. Sorry, closing ticket.

aezell added a comment.Apr 8 2020, 8:24 PM

Hi @AS, thanks for validating that. I'm glad that there's not a bug we introduced but I'm bummed that this is a problem.

I guess the gadget hasn't been updated to be aware of partial blocks.

@aezell indeed, we didn't update the relevant gadget, while its enwiki counterpart fixed the problem quite quickly (they had this discussion, where it was suggested to use a restrictions property for the bkprop parameter, as described here). Anyway, the problem seems to be solved now, thanks!