Page MenuHomePhabricator

Inconsistent naming in RevisionDelete
Open, NormalPublic

Description

Users are familiar with &action=delete which has been called as 'Delete' for a long time.

When the new RevisionDelete system comes, users may get confused because of the name. Names used currently include:

'delete' - special page name, many messages
'remove' - log entries
'hide' - index.php parameters, right names
'suppress' - right names
'oversight' - old name in that extension (not used now?)

We should find a consistent name for this new feature.


Version: unspecified
Severity: enhancement

Details

Reference
bz22672

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:09 PM
bzimport set Reference to bz22672.
bzimport added a subscriber: Unknown Object (MLST).
liangent created this task.Feb 28 2010, 6:45 AM

matthew.britton wrote:

Distinguishing the removal of entire pages from the removal of revisions is important. That said, there's no reason to have any more than two names for things.

'oversight' should be ditched (frankly the whole extension should be ditched), it's a stupid name for the concept in the first place. I'd be happy with "delete" for pages and "hide" for everything else.

happy.melon.wiki wrote:

On enwiki at least, oversighters (that term to describe the group is not going to go away) have adopted the practice of using the terms "oversight" to the process as a whole, "suppress" to refer to hiding material from administrators as well as regular users, and "redact" when hiding only from users. In particular, the distinction between "redact" and "suppress" helps us keep the two activities separate; "redaction" is also kept distinct from "deletion", referring as it does to hiding individual revisions rather than the whole page.

Bug 38378 might be a duplicate.

  • Bug 38378 has been marked as a duplicate of this bug. ***

Adding many blockers of bug 38638 to the list of "easy" bugs, to mark them as candidates for [[mw:Google Code-in]] tasks (gci2013). If you think this bug is not suitable, remove the keyword.

MC8 set Security to None.
MC8 added a subscriber: MC8.

Removing "easy" tag as this is still under discussion -- deciding on a name is hard!
Once we pick something, we can re-add the tag once there's actually something to implement.

jrbs added a subscriber: jrbs.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 30 2015, 12:11 AM
Meno25 removed a subscriber: Meno25.Feb 19 2016, 5:46 PM
Restricted Application added a subscriber: JEumerus. · View Herald TranscriptFeb 19 2016, 5:46 PM