Page MenuHomePhabricator

'Add qualifier' field displays 'Unsupported data type' default text
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  1. On production (e.g. https://commons.wikimedia.org/wiki/File:Malibu-superbloom.jp) or in betacluster (e.g. https://commons.wikimedia.beta.wmflabs.org/wiki/File:Icon_for_char_%E8%AB%B5_darkslateblue_plum_32x32.png) click on 'Structured data'.
  2. Click on 'Edit' and then on 'Add qualifier' - the field will display the default text "Unsupported data type".

Actual Results:

Expected Results:
The text should inform users what should go into this field (or it might be just blank). The existing text doesn't provide users with helpful info.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 6 2020, 12:05 AM
Ramsey-WMF added subscribers: AnneT, Cparle.

Looks like something for you, Eric 😺 (although maybe Anne as well)

This looks like a situation where we need to apply a different label (or simply show no label at all) in the second disabled field before the user has specified a property in the first field. I propose we handle this situation like so:

  1. User is clicks "add qualifier". A new row appears with empty inputs for property and value. The value input is disabled and has no label at all.
  2. User types/selects a property. The value input updates to become an input of the appropriate type.
  3. If the user selects a type that happens to be unsupported, they see the disabled value input with "unsupported data type" message like we see here.

Can you confirm what behavior you'd like to see here?

This is exactly what I was hoping for 👇

This looks like a situation where we need to apply a different label (or simply show no label at all) in the second disabled field before the user has specified a property in the first field. I propose we handle this situation like so:

  1. User is clicks "add qualifier". A new row appears with empty inputs for property and value. The value input is disabled and has no label at all.
  2. User types/selects a property. The value input updates to become an input of the appropriate type.
  3. If the user selects a type that happens to be unsupported, they see the disabled value input with "unsupported data type" message like we see here.

Can you confirm what behavior you'd like to see here?

Change 577715 had a related patch set uploaded (by Eric Gardner; owner: Eric Gardner):
[mediawiki/extensions/WikibaseMediaInfo@master] Hide "unsupported data type" label when user adds a new qualifier

https://gerrit.wikimedia.org/r/577715

Cparle added a comment.Mar 9 2020, 3:53 PM
This comment was removed by Cparle.

Change 577715 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Remove label from UnsupportedInputWidget

https://gerrit.wikimedia.org/r/577715

Ramsey-WMF closed this task as Resolved.Mar 23 2020, 6:15 PM
Ramsey-WMF claimed this task.
Ramsey-WMF added a subscriber: egardner.

Verified working on production.