When I refreshed the page I was sent back to the login screen. Second attempt was fine.
Description
When I refreshed the page I was sent back to the login screen. Second attempt was fine.
Related Objects
- Mentioned Here
- T240852: CloudVPS: horizon giving http/500 intermitently
Event Timeline
Now it happens when I switch to a different project sometimes - after refresh it's fine.
<Krenair> "There are no allowed boot sources. If you think this is wrong please contact your administrator."
<Krenair> This is where I'm supposed to select stretch vs. buster in the horizon instance launch UI
<Krenair> without it I can't launch an instance. this is the testlabs project btw
<Krenair> gonna open a task
<Krenair> actually given the session errors popping up I suspect it may be related, will leave comments in my existing horizon-500-bug task
also occurs in cloudinfra
labweb1002 is throwing an error we saw not too long ago in T240852. I'll restart apache there and see if that fixes it until we have time to look at it closer.
2020-03-08 18:54:38.986273 raise RuntimeError("populate() isn't reentrant")
2020-03-08 18:54:38.986301 RuntimeError: populate() isn't reentrantNote that we're seeing this intermittently due to the load balancer using round-robin between labweb1001 and labweb1002.
Mentioned in SAL (#wikimedia-cloud) [2020-03-08T19:04:45Z] <jeh> restart apache2 to clear up horizon error on labweb1002 T247199
Created an instance and switched between a few projects and all seems fine now, thanks @JHedden
