Page MenuHomePhabricator

Broken section edit links styles on Vector
Closed, ResolvedPublic

Description

On https://en.wikipedia.beta.wmflabs.org/wiki/Talk:Cats, the "edit source" links are huge. This looks like some important styles are not loading.

Other skins look OK (I tested MonoBook).

Event Timeline

matmarex created this task.Thu, Mar 12, 9:09 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptThu, Mar 12, 9:09 PM
matmarex triaged this task as Unbreak Now! priority.Thu, Mar 12, 9:09 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptThu, Mar 12, 9:09 PM
matmarex updated the task description. (Show Details)Thu, Mar 12, 9:09 PM

Looks fixed now… was there a patch, or was this some Beta Cluster brokenness?

Demian added a subscriber: Demian.Fri, Mar 13, 4:33 PM

Some time after you reported it I couldn't reproduce the issue: the "edit source" links were normal on the page you've linked.

Aklapper updated the task description. (Show Details)

This has somehow been unfixed and is now broken on https://test.wikipedia.org/wiki/User_talk:Matma_Rex.

DOM structure is unchanged, so did the styling change?

Melos added a subscriber: Melos.Thu, Mar 19, 12:32 AM

I have seen this bug on my local installation when the core version is updated to 1.35.0-wmf.24 and vector version remains to 1.35.0-wmf.23.

I don't see the breakage

Seen on both testwiki and mediawiki.org now.

Related probably: On office wiki, the print footer is visible on desktop, and thumbnails are no longer aligned to the side.

DannyS712 added a subscriber: DannyS712.

Just came across this and was about to report

I'm unsure but I think the presentation is missing a .mw-editsection rule:

resources/src/mediawiki.skinning/legacy.less
/* Display editsection links smaller and next to headings */
.mw-editsection,
.mw-editsection-like {
  font-size: small; /* <-------- */
  font-weight: normal;
  margin-left: 1em;
  vertical-align: baseline;
  /* Reset line-height; headings tend to have it set to larger values */
  line-height: 1em;
}

It seems to be related to a change in Core but I'm having trouble bisecting it so far.

I think it's 73c20062e0 unfortunately.

Change 581224 had a related patch set uploaded (by Niedzielski; owner: Stephen Niedzielski):
[mediawiki/core@master] Revert "mediawiki.legacy.shared is merged into existing skin modules and removed"

https://gerrit.wikimedia.org/r/581224

^I've taken a stab at a revert but I think there may be dependency fan out issues for the skins. It would be much, much better if a proper fix can be made instead both to minimize risk and not lose the work put in thus far. @Jdlrobson, can you take a look at this tomorrow?

Change 581238 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/Vector@master] skins.vector.styles.legacy needs to define legacy feature

https://gerrit.wikimedia.org/r/581238

^I've taken a stab at a revert but I think there may be dependency fan out issues for the skins. It would be much, much better if a proper fix can be made instead both to minimize risk and not lose the work put in thus far. @Jdlrobson, can you take a look at this tomorrow?

I can see exactly what the issue. Revert won't help here as new HTML is already in cache.
Have taken a copy of a page with the issue here > P10727. Looks like there was a rebase issue. skins.vector.styles.legacy needs to define the "legacy" feature so no caching implications with the fix here. Above patch should take care of it ^

Change 581248 had a related patch set uploaded (by Krinkle; owner: Jdlrobson):
[mediawiki/skins/Vector@wmf/1.35.0-wmf.24] skins.vector.styles.legacy needs to define legacy feature

https://gerrit.wikimedia.org/r/581248

Change 581224 abandoned by Niedzielski:
Revert "mediawiki.legacy.shared is merged into existing skin modules and removed"

https://gerrit.wikimedia.org/r/581224

Change 581238 merged by jenkins-bot:
[mediawiki/skins/Vector@master] skins.vector.styles.legacy needs to define legacy feature

https://gerrit.wikimedia.org/r/581238

So this seems to be affecting group0 wikis and generating complaints. Patch should probably be backported and deployed rather urgently

Stryn added a subscriber: Stryn.Thu, Mar 19, 8:26 AM
hashar added a subscriber: hashar.Thu, Mar 19, 8:47 AM

I am the train conductor this week but I can not deploy anything in the morning (home schooling due to the virus). Anyone has my blessing to have https://gerrit.wikimedia.org/r/#/c/581248/ deployed.

phuedx added a subscriber: phuedx.Thu, Mar 19, 9:40 AM

I've scheduled https://gerrit.wikimedia.org/r/c/mediawiki/skins/Vector/+/581248 for deployment during today's European mid-day SWAT window.

Change 581248 merged by jenkins-bot:
[mediawiki/skins/Vector@wmf/1.35.0-wmf.24] skins.vector.styles.legacy needs to define legacy feature

https://gerrit.wikimedia.org/r/581248

Mentioned in SAL (#wikimedia-operations) [2020-03-19T10:24:50Z] <ladsgroup@deploy1001> Synchronized php-1.35.0-wmf.24/skins/Vector/skin.json: [[gerrit:581248|skins.vector.styles.legacy needs to define legacy feature (T247566)]] (duration: 01m 08s)

Ladsgroup closed this task as Resolved.Thu, Mar 19, 10:28 AM
Ladsgroup assigned this task to Jdlrobson.