Page MenuHomePhabricator

Interwiki link problem on various wikis
Closed, ResolvedPublic

Description

When trying to add interwiki links to a page on Wiktionary, it tries to match with Wikisource pages. Also when tried the same on Wikisource, wikipedia links show up.

Seems like adding sitelink from Wikibase client (aka Wikipedia) is broken - it looks up for wrong current site (for example hewiki thinks it is jawiktionary) and it isn't possible to link to other site.

How to reproduce

  1. Go to page not connected to item such as: https://he.wikipedia.org/wiki/יעקב_טולידאנו_(קהלת_יעקב)?uselang=en
  2. Press "add links"
  3. in the site field fill enwiki - note it will suggest enwiktionary (not enwiki)

root cause
I couldn't determine the exact root cause, but quick debug point to

wikibase.client.linkitem.init.js

and specifically this line: config = require( './config.json' ).currentSite

returns wrong site. (maybe not deterministic - but at least once I saw jawiktionary instead of hewiki)

I'm not sure what "require" points to - and whether this is just site configuration or code issue - so I'm adding all the suspects as tags

Turkish Wiktionary
Tried this on Wiktionary:Images. You could test it there with Vikisözlük:Resimler on Turkish Wiktionary.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 15 2020, 7:58 PM
HastaLaVi2 updated the task description. (Show Details)Mar 15 2020, 8:17 PM
Billinghurst added a subscriber: Billinghurst.EditedMar 16 2020, 11:27 AM

It looks like a new item was created by whatever you were doing if I look at
https://www.wikidata.org/w/index.php?title=Q87748026&action=history
which was created by you and was moved by you to the other item
https://www.wikidata.org/w/index.php?title=Q13391335&action=history

We are going to need a better step by step guide to replication if we are to investigate the Wikisource side. From the wikidata item I am only seeing the appropriate linking offering from the proper wikis.

Aklapper changed the task status from Open to Stalled.Mar 16 2020, 12:33 PM

Hi @HastaLaVi2, thanks for taking the time to report this. Unfortunately this Wikimedia Phabricator task lacks some information.
If you have time and can still reproduce the situation: Please add a more complete description to this task. That should be

  • a clear list of exact steps to reproduce the situation, step by step, so that nobody needs to guess or interpret how you performed each step,
  • what happens after performing these steps to reproduce,
  • what you expected to happen instead,
  • a full link to a web address where the issue can be seen.

You can edit the task description by clicking Edit Task. Ideally, a good description should allow any other person to follow these steps (without having to interpret steps) and see the same results. Problems that others can reproduce can get fixed faster. We appreciate people who report issues, so thanks again!

Hi @Aklapper, the problem is solved somehow. I do not know how though. Thank you for your interest.

No, now there is another problem, I am going to explain in more detail.

Ok so,

  1. Go to the page Wiktionary:Images on English Wiktionary.
  2. On the sidebar, under languages tab, there is "add links". Click on it.
  3. From the window try to add an interwiki link to Vikisözlük:Resimler, which is equivalent page on Turkish Wiktionary.
  4. It says "Wiktionary:Images" could not be found in ruwiktionary. So it thinks that we are making this change on Russion Wiktionary, when we are actually on English Wiktionary.

Now we are going to try the opposite of this, adding the English link from Turkish Wiktionary;

  1. Go to the page Vikisözlük:Resimler on Turkish Wiktionary.
  2. From the sidebar under "diller" (languages) tab click on "bağlantı ekle" (add links).
  3. Now from the same tab, we are going to try adding Wiktionary:Images from English Wiktionary.
  4. This time you will see that on the first textarea, when you type "en", enwiki shows up, which is the English Wikipedia, what we want is English Wiktionary. This time we won't be able to search any page at all.

I hope this is more understandable. Thanks.

Urbanecm changed the task status from Stalled to Open.Mar 17 2020, 8:15 AM
Urbanecm added a subscriber: Urbanecm.

This is a proven issue it seems, see the two merged tasks and author's comment.

Robby added a subscriber: Robby.Mar 17 2020, 9:28 AM
eranroz updated the task description. (Show Details)Mar 17 2020, 8:05 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptMar 18 2020, 8:29 AM

Suspected to be related: T247078

Amir suspects the root cause is in T247562. Will wait for that to be fixed.

The other ticket is closed now and it seems to be fine for me again now. Anyone still seeing issues or can we close this?

Jdforrester-WMF closed this task as Resolved.Mar 18 2020, 3:55 PM
Jdforrester-WMF assigned this task to Krinkle.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

This appears to be fixed, yes.