Page MenuHomePhabricator

Interwiki tool not working in cawiki and cawikitionary
Closed, DuplicatePublic

Description

When you click on ''Add links'' to add interlanguage links on a cawiki article, it does not allow to link to enwiki, for example, and you're able to choose only, for example, enwikibooks.

This happens randomly: sometimes it happens and sometimes, it doesn't. It also happens in cawiktionary.

The workaround is to link from the equivalent page in another language or from wikidata itself.

Last discussion with links links to three other discussions about the same topic: https://ca.wikipedia.org/wiki/Tema:Vinajutl5v4dd3oo

Event Timeline

Paucabot created this task.Mar 15 2020, 8:19 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 15 2020, 8:19 PM
Reedy added a subscriber: Reedy.Mar 15 2020, 8:25 PM

Where is "Add links"?

RhinosF1 added a subscriber: RhinosF1.EditedMar 15 2020, 8:29 PM

Where is "Add links"?

Under the languages list in sidebar?

Reedy added a comment.EditedMar 15 2020, 8:30 PM

No there isn't (on all pages)

No there isn't (on all pages)

That's because there are language links already. When a page is not yet linked to any interwiki link, that's when "Add links" appears

Reedy added a comment.Mar 15 2020, 8:39 PM

That's because there are language links already. When a page is not yet linked to any interwiki link, that's when "Add links" appears

Right, but that makes it a poor bug report

Aklapper changed the task status from Open to Stalled.Mar 15 2020, 10:04 PM

Hi @Paucabot, thanks for taking the time to report this! Unfortunately this Wikimedia Phabricator task lacks some information.
If you have time and can still reproduce the situation: Please add a more complete description to this task. That should be

  • a clear list of exact steps to reproduce the situation, step by step, so that nobody needs to guess or interpret how you performed each step,
  • what happens after performing these steps to reproduce,
  • what you expected to happen instead,
  • a full link to a web address where the issue can be seen, instead of "a cawiki article".

Thanks!

It is unstable, sometimes it works and sometimes it does not. On page https://ca.wiktionary.org/wiki/Categoria:Mots_en_catal%C3%A0_amb_sufix_-cele click "add links". In the pop-up try to enter any "language". It offers to select a Wikibooks project, so you can not link to other Wiktionary project as expected. You can try also in Wikipedia with lastest page from Special:NewPages. Usually people ask for help and it is solved by other ways. FWIW, first report of malfunction was some hours after deploying new version 1.35.0-wmf.23 (rMW86361b484905)

FWIW, first report of malfunction was some hours after deploying new version 1.35.0-wmf.23 (rMW86361b484905)

This is fairly useful information ;)

Paucabot added a comment.EditedMar 16 2020, 12:28 PM

That's because there are language links already. When a page is not yet linked to any interwiki link, that's when "Add links" appears

Right, but that makes it a poor bug report

I tried to make it the best I could. English is not my language and I am not a software enginner. Thanks for understanding it.