Page MenuHomePhabricator

Extract HTML of the RecordWizard outside the JS code by using mustache templates
Closed, ResolvedPublic

Description

The code of the RecordWizard currently mix view and controller; php-pregenerated HTML using mustache templates should enhance this, in addition to be more time-saving than js-generated HTML.

Event Timeline

0x010C created this task.Mar 17 2020, 3:57 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 17 2020, 3:57 PM
0x010C renamed this task from Refactor code by using mustache templates to Extract HTML of the RecordWizard outside the JS code by using mustache templates.Mar 31 2020, 1:35 PM

All the new RecordWizard-related mock-ups (see T212581) have been implemented using mustache as described. The result can for now on be seen on the development website. Note that all the interactions are not yet plugged with this new interface (T248983 is still a WIP), thus the two last steps may not work as intended yet.

0x010C closed this task as Resolved.Jun 2 2020, 10:40 AM