Page MenuHomePhabricator

Move scap plugins from mediawiki-config repo to scap repo
Open, MediumPublic

Description

Follow-up to T248040.

Revisions and Commits

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 25 2020, 5:16 PM
thcipriani triaged this task as Medium priority.

Change 599973 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/tools/scap@master] Move scap plugins from mediawiki-config into this repo

https://gerrit.wikimedia.org/r/599973

Change 599973 merged by jenkins-bot:
[mediawiki/tools/scap@master] Move scap plugins from mediawiki-config into this repo

https://gerrit.wikimedia.org/r/599973

Change 601388 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[operations/mediawiki-config@master] Drop scap plugins, moved into scap proper

https://gerrit.wikimedia.org/r/601388

LarsWirzenius removed LarsWirzenius as the assignee of this task.Aug 13 2020, 1:48 PM
LarsWirzenius added a subscriber: LarsWirzenius.

Change 601388 merged by jenkins-bot:
[operations/mediawiki-config@master] Drop scap plugins, moved into scap proper

https://gerrit.wikimedia.org/r/601388

Jdforrester-WMF closed this task as Resolved.Sep 30 2020, 4:37 PM
Jdforrester-WMF claimed this task.
mmodell added a subscriber: mmodell.

rOMWC658f28991a78 broke deployments. scap update-wikiversions was removed and apparently it's not in scap core.

rOMWC658f28991a78 broke deployments. scap update-wikiversions was removed and apparently it's not in scap core.

It was added in https://gerrit.wikimedia.org/r/c/mediawiki/tools/scap/+/599973/1/scap/plugins/updatewikiversions.py surely?

missing on deploy1001 .. did the new version actually get rolled out to all of production?

~~~sh
liw@deploy1001:~$ scap version
3.15.0-1
liw@deploy1001:~$ dpkg -L scap | grep wikiversions
/usr/lib/python2.7/dist-packages/scap/plugins/updatewikiversions.py
liw@deploy1001:~$
~~~

The plugin is in the version on deploy1001, but Scap doesn't find it. I did not notice this when adding the plugins to Scap. I'll figure out what the problem is and submit a fix.

This is what I get for touching software that lacks test suites, I guess. Sorry.

Jdforrester-WMF reopened this task as Open.Oct 1 2020, 4:49 PM

Reverted as scap lost track of (some of?) the plugins.

Change 633205 had a related patch set uploaded (by Lars Wirzenius; owner: Lars Wirzenius):
[mediawiki/tools/scap@master] fix: find plugins again

https://gerrit.wikimedia.org/r/633205

Change 633205 merged by jenkins-bot:
[mediawiki/tools/scap@master] fix: find plugins again

https://gerrit.wikimedia.org/r/633205