Page MenuHomePhabricator

[Bug] TypeError: clone.attributes is undefined on signature
Closed, ResolvedPublicBUG REPORT

Description

Steps to reproduce

  1. Visit https://www.mediawiki.org/wiki/Reading/Web/Chores?veaction=edit (or edit any other page where signatures can be inserted)
  2. Insert your signature by typing ~~~~ anywhere
  3. Delete it

Expected results

  • No error

Actual results

  • TypeError and editor misbehaves

Environments observed

  • Browser version: Mozilla Firefox 74.0
  • OS version: Ubuntu v19.10
  • Device model: Desktop
  • Device language: English

Stack trace

Console output
TypeError: clone.attributes is undefined
cloneElement https://www.mediawiki.org/w/extensions/VisualEditor/modules/ve-mw/dm/nodes/ve.dm.MWTransclusionNode.js?014f5:301
    getClonedElement https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.Node.js?8d3b2:418
    pushRemoveNodeOp https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.TreeModifier.js?14f43:825
    pushRemoveLast https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.TreeModifier.js?14f43:705
    pushRemoveLastIfInDeletions https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.TreeModifier.js?14f43:715
    processRemove https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.TreeModifier.js?14f43:634
    processLinearOperation https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.TreeModifier.js?14f43:429
    calculateTreeOperations https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.TreeModifier.js?14f43:406
    process https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.TreeModifier.js?14f43:371
    process https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.TransactionProcessor.js?6ca1d:111
    commit https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.Document.js?4bdbd:341
    changeInternal https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.Surface.js?d7851:976
    change https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.Surface.js?d7851:944
    change https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.SurfaceFragment.js?38406:126
    removeContent https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.SurfaceFragment.js?38406:939
    insertContent https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/dm/ve.dm.SurfaceFragment.js?38406:802
    execute https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/ce/keydownhandlers/ve.ce.TableDeleteKeyDownHandler.js?f6262:66
    handleInsertion https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/ce/ve.ce.Surface.js?4b412:4027
    onDocumentKeyPress https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/ce/ve.ce.Surface.js?4b412:1530
    <anonymous> self-hosted:876
    callListener https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/ve.EventSequencer.js?f7898:439
    onEvent https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/ve.EventSequencer.js?f7898:266
    makeEventHandler https://www.mediawiki.org/w/extensions/VisualEditor/lib/ve/src/ve.EventSequencer.js?f7898:65
jQuery 2
        dispatch
        handle

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 26 2020, 2:29 PM
Niedzielski updated the task description. (Show Details)Mar 26 2020, 2:34 PM

I can't reproduce in Chrome or FF. Can you still reproduce in a clean session (and logged out)? Can anyone else reproduce?

I am not seeing a 100% reproduction rate any more but I can reproduce in Firefox incognito (logged out, brand new session). Example gif.

This is reproducible easily by just adding a signature anywhere on any page, then deleting it.

Change 595688 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Fix deleting signature nodes

https://gerrit.wikimedia.org/r/595688

Change 595688 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Fix deleting signature nodes

https://gerrit.wikimedia.org/r/595688

matmarex added a project: Editing QA.
matmarex updated the task description. (Show Details)
ppelberg closed this task as Resolved.May 21 2020, 11:38 PM
ppelberg claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMay 21 2020, 11:38 PM