It would be a breaking change to have it return a RevisionRecord instead, which is what it probably should be returning
$this->mBaseRevision = $revRecord ? new Revision( $revRecord ) : null;
The method also has a warning note
@warning this method is very poorly named. If the user opened the form with ?oldid=X, one might think of X as the "base revision", which is NOT what this returns, see oldid for that. One might further assume that this corresponds to the $baseRevId parameter of WikiPage::doEditContent, which is not the case either. getExpectedParentRevision() would perhaps be a better name.
Introduce EditPage::getExpectedParentRevision (or ...ParentRevisionRecord?) that returns a RevisionRecord instead
Have EditPage::getBaseRevision be a wrapper for the new method that returns a revision instead of a revision record
Replace uses in WMF deployed code, deprecate, etc