Page MenuHomePhabricator

Nuke does not work or is documented poorly
Closed, InvalidPublic

Description

https://www.mediawiki.org/wiki/Topic:Tixb1x1ksygaby5c and https://stackoverflow.com/questions/40288145/how-to-delete-mediawiki-pages-using-nuke-and-pywikibot ask how nuke works.

If i try it out my self with Special:Nuke&action=submit on my MediaWiki 1.27.3 entering my username and a wildcard "%something%" i get No new pages in recent changes. When i click on the username link a few dozen pages which mach the pattern show. Whats wrong with the extension and or it's documentation?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 27 2020, 12:05 PM
Aklapper closed this task as Invalid.Mar 27 2020, 12:35 PM

Hi, MediaWiki 1.27 is an insecure old unsupported software version. Feel free to create a new task and follow https://www.mediawiki.org/wiki/How_to_report_a_bug (clear steps to reproduce as a list, expected outcome, actual outcome, etc) if this problem still happens with supported software versions. Thanks!

Seppl2013 added a comment.EditedMar 27 2020, 2:12 PM

1.27 is the only version we can currently use. That is unsupported is very unfortunated but we can't migrate although we are trying hard. Too many breaking changes have been introduced in the last few months and we don not have the capacity to keep up with all these incompatible changes. Not being able to use the nuke extension does not help for the migration since we still have a lot of tests to do in which we generate pages and need to quickly remove them again.

Indeed on 1.33.2 things seem to work as advertised.

1.27 is the only version we can currently use.

Ah, pity. :( In that case, please avoid filing tasks if the problem has not first been confirmed in a supported version, and refer to the mediawiki.org Support Desk instead.