Page MenuHomePhabricator

Domain of sender address of Wikimedia mail notifications is set to mw1337.eqiad.wmn for emails from Sinhala Wikipedia
Closed, ResolvedPublic

Description

Hello,

Emails received from Sinhala Wikipedia comes with the following as sender name:

=?UTF-8?Q?=E0=B7=80=E0=B7=92=E0=B6=9A=E0=B7=92=E0=B6=B4=E0=B7=93=E0=B6=A9=E0=B7=92=E0=B6=BA=E0=B7=8F@mw1318.eqiad.wmnet

As opposed to just "Wikipedia" on other projects.

I'm referring to emails which are activated by selecting "Email me when a page or a file on my watchlist is changed" via https://si.wikipedia.org/wiki/Special:Preferences.

My browser supports Sinhala Language characters. I.e. The subject line comes in Sinhala language.

I received emails to Microsoft Outlook (browser version).

Thanks,
Rehman

Event Timeline

Rehman created this task.Mar 31 2020, 4:07 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 31 2020, 4:07 PM
Aklapper changed the task status from Open to Stalled.Mar 31 2020, 5:59 PM
Aklapper removed a project: MediaWiki-General.

Hi @Rehman, thanks for taking the time to report this! Could you attach an example email including full mail headers (and make sure to obfuscate/replace any personal data like IP addresses or email addresses, as Phabricator is a public place)?
Or if you don't want that, could you forward such an email (including its full mail headers) to my email address? Thanks!

Rehman added a comment.Apr 1 2020, 1:36 AM

Hi @Rehman, thanks for taking the time to report this! Could you attach an example email including full mail headers (and make sure to obfuscate/replace any personal data like IP addresses or email addresses, as Phabricator is a public place)?
Or if you don't want that, could you forward such an email (including its full mail headers) to my email address? Thanks!

Hi @Aklapper , I've forwarded the whole email to you. Does it contain the needed information?

Aklapper renamed this task from Gibberish sender name on emails from Sinhala Wikipedia to Domain of sender address of Wikimedia mail notifications is set to mw1337.eqiad.wmn for emails from Sinhala Wikipedia.Apr 1 2020, 11:56 AM
Aklapper changed the task status from Stalled to Open.
Aklapper added a project: Mail.
Aklapper added a project: Operations.

It does, thanks for forwarding that email! I imported your email into my email application:

Indeed something seems wrong on the Wikimedia side, as the sender address shows mw1337.eqiad.wmn as domain. (And something went wrong when it comes to the character encoding of the email body, but if you don't see that problem I guess something went wrong when you exported that email.)

Indeed something seems wrong on the Wikimedia side, as the sender address shows mw1337.eqiad.wmn as domain. (And something went wrong when it comes to the character encoding of the email body, but if you don't see that problem I guess something went wrong when you exported that email.)

Good spot, I didn't notice the characters in the email body.

I've retried copying again, it seems like the characters display properly in the email body, but converts to those odd symbols in the 'view source' window which I've mentioned to you on email. Not too sure if this is supposed to be normal behaviour.

(If you copied and pasted something from somewhere, instead of directly *saving* the full email, then there will nearly always be issues.)

(If you copied and pasted something from somewhere, instead of directly *saving* the full email, then there will nearly always be issues.)

Sorry I wasn't clear. The odd symbols are visible before copying, in the original email source.

jcrespo added a subscriber: jcrespo.Apr 2 2020, 2:14 PM

@Rehman Thanks for reporting. I can reproduce the error.

First of all, don't be alarmed- this is looks just like an interface error. The 1337 doesn't mean anything was compromised, it look just a random application server writing the email (sending the server name instead of the normal address). For example, I received an email with the following from:

විකිපීඩියා@mw1321.eqiad.wmnet, නිදහස් විශ්වකෝෂය <wiki@wikimedia.org>

Please confirm this translates or transliterates to
wikipedia@mw1321.eqiad.wmnet, The free Encyclopedia

mw1321.eqiad.wmnet is public information and can be even seen on every page rendering's source code.

While Operations was added to this ticket, and I cannot discard an email issue, it is likely and I would search for the issue on one of these 2 areas first:

  • A bug on internationalization (translation) for Sinhalese language: probably the wrong translation was imported into the wiki recently, causing it to write the hostname of the server when sending an email.
  • A bug on configuration for siwiki

Language-Team could you help us understand if a bad translation was merged recently for the SI language, causing bad email froms to be sent?

Of course please re add operations if the issue is not there or on mediawiki-configuration.

wmf-config/VariantSettings.php  'siwiki' => 'විකිපීඩියා, නිදහස් විශ්වකෝෂය',

On the other hand, I can see the above configuration for the name of the wiki, which I may be wrong (obviously I am not a speaker), but doesn't look right to me (does it really need the comma on the title for the short name?

Change 585509 had a related patch set uploaded (by Jcrespo; owner: Jcrespo):
[operations/mediawiki-config@master] InitializeSettings: Update site name for siwiki, causes formatting issues

https://gerrit.wikimedia.org/r/585509

Could someone with the language knowledge (in addition to someone with Mediawiki configuration knowledge :-)) would know if the above patch makes sense?

Change 585509 merged by jenkins-bot:
[operations/mediawiki-config@master] [siwiki] Change wgSitename to drop the ',' as it causes formatting issues

https://gerrit.wikimedia.org/r/585509

Jdforrester-WMF closed this task as Resolved.Apr 2 2020, 4:32 PM
Jdforrester-WMF assigned this task to jcrespo.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Deployed.

Mentioned in SAL (#wikimedia-operations) [2020-04-02T16:32:58Z] <jforrester@deploy1001> Synchronized wmf-config/InitialiseSettings.php: T249014 [siwiki] Change wgSitename to drop the ',' (duration: 01m 07s)

Mentioned in SAL (#wikimedia-operations) [2020-04-02T16:33:07Z] <jforrester@deploy1001> sync-file aborted: T249014 [siwiki] Change wgSitename to drop the ',' (duration: 00m 00s)

Confirmed fixed: