Page MenuHomePhabricator

Deprecated: Use of parserTest v1 in Scribunto and SyntaxHighlight
Closed, ResolvedPublic

Description

I'm unable to merge changes to MassMessage:

10:58:22 There were 2 errors:
10:58:22 
10:58:22 1) SpecialPageFatalTest::testSpecialPageDoesNotFatal with data set "RunJobs" (SpecialRunJobs Object (...))
10:58:22 === Logs generated by test case
10:58:22 [objectcache] [debug] MainWANObjectCache using store {class} {"class":"EmptyBagOStuff"}
10:58:22 [wfDebug] [debug] IP: 127.0.0.1 {"private":false}
10:58:22 ===
10:58:22 Headers already sent, should send headers earlier than wfHttpError [Called from MediaWiki\HeaderCallback::warnIfHeadersSent in /workspace/src/includes/HeaderCallback.php at line 74]
10:58:22 
10:58:22 /workspace/src/includes/debug/MWDebug.php:333
10:58:22 /workspace/src/includes/debug/MWDebug.php:188
10:58:22 /workspace/src/includes/HeaderCallback.php:74
10:58:22 /workspace/src/includes/libs/HttpStatus.php:104
10:58:22 /workspace/src/includes/GlobalFunctions.php:1595
10:58:22 /workspace/src/includes/specials/SpecialRunJobs.php:50
10:58:22 /workspace/src/tests/phpunit/includes/specials/SpecialPageExecutor.php:107
10:58:22 /workspace/src/tests/phpunit/includes/specials/SpecialPageExecutor.php:37
10:58:22 /workspace/src/tests/phpunit/structure/SpecialPageFatalTest.php:33
10:58:22 /workspace/src/tests/phpunit/MediaWikiIntegrationTestCase.php:418
10:58:22 /workspace/src/maintenance/doMaintenance.php:99
10:58:22 
10:58:22 2) SpecialPageFatalTest::testSpecialPageDoesNotFatal with data set "JavaScriptTest" (SpecialJavaScriptTest Object (...))
10:58:22 === Logs generated by test case
10:58:22 [objectcache] [debug] MainWANObjectCache using store {class} {"class":"EmptyBagOStuff"}
10:58:22 [wfDebug] [debug] IP: 127.0.0.1 {"private":false}
10:58:22 [MessageCache] [debug] MessageCache using store {class} {"class":"HashBagOStuff"}
10:58:22 [wfDebug] [debug] User: cache miss for user 1 {"private":false}
10:58:22 [wfDebug] [debug] User: loading options for user 1 from database. {"private":false}
10:58:22 [objectcache] [debug] fetchOrRegenerate(global:user:id:wikidb-unittest_:1): miss, new value computed []
10:58:22 [wfDebug] [debug] ParserFactory: using default preprocessor {"private":false}
10:58:22 ===
10:58:22 Cannot modify header information - headers already sent by (output started at /workspace/src/includes/debug/MWDebug.php:333)
10:58:22 
10:58:22 /workspace/src/includes/specials/SpecialJavaScriptTest.php:194
10:58:22 /workspace/src/includes/specials/SpecialJavaScriptTest.php:53
10:58:22 /workspace/src/tests/phpunit/includes/specials/SpecialPageExecutor.php:107
10:58:22 /workspace/src/tests/phpunit/includes/specials/SpecialPageExecutor.php:37
10:58:22 /workspace/src/tests/phpunit/structure/SpecialPageFatalTest.php:33
10:58:22 /workspace/src/tests/phpunit/MediaWikiIntegrationTestCase.php:418
10:58:22 /workspace/src/maintenance/doMaintenance.php:99
10:58:22 
10:58:22 ERRORS!

I'm guessing this can be the cause:

10:56:52 Deprecated: Use of parserTest v1: /workspace/src/extensions/Scribunto/tests/parser/luaParserTests.txt was deprecated in MediaWiki 1.35. [Called from TestFileReader::execute in /workspace/src/tests/parser/TestFileReader.php at line 251] in /workspace/src/includes/debug/MWDebug.php on line 333
10:56:52 PHP Deprecated:  Use of parserTest v1: /workspace/src/extensions/Scribunto/tests/parser/luaParserTests.txt was deprecated in MediaWiki 1.35. [Called from TestFileReader::execute in /workspace/src/tests/parser/TestFileReader.php at line 251] in /workspace/src/includes/debug/MWDebug.php on line 333
10:56:52 
10:56:52 Deprecated: Use of parserTest v1: /workspace/src/extensions/SyntaxHighlight_GeSHi/tests/parser/parserTests.txt was deprecated in MediaWiki 1.35. [Called from TestFileReader::execute in /workspace/src/tests/parser/TestFileReader.php at line 251] in /workspace/src/includes/debug/MWDebug.php on line 333
10:56:52 PHP Deprecated:  Use of parserTest v1: /workspace/src/extensions/SyntaxHighlight_GeSHi/tests/parser/parserTests.txt was deprecated in MediaWiki 1.35. [Called from TestFileReader::execute in /workspace/src/tests/parser/TestFileReader.php at line 251] in /workspace/src/includes/debug/MWDebug.php on line 333

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 2 2020, 8:06 AM
Nikerabbit triaged this task as Unbreak Now! priority.Apr 2 2020, 8:08 AM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptApr 2 2020, 8:08 AM

Change 585429 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[mediawiki/core@master] Revert "Deprecate parserTests format v1"

https://gerrit.wikimedia.org/r/585429

DannyS712 moved this task from Unsorted to Awaiting review and deployment on the User-DannyS712 board.
DannyS712 added a subscriber: DannyS712.

Not definitively claiming since I'm going offline for ~7 hours and someone else may see a different fix

Change 585429 merged by jenkins-bot:
[mediawiki/core@master] Revert "Deprecate parserTests format v1"

https://gerrit.wikimedia.org/r/585429

Nikerabbit closed this task as Resolved.Apr 2 2020, 9:22 AM
Nikerabbit assigned this task to DannyS712.
cscott added a subscriber: cscott.Apr 2 2020, 4:59 PM

Seems right. Looks like there were a couple of v1 parserTests not included in the jenkins jobs for merging patches to core...

cscott renamed this task from Failing test: SpecialPageFatalTest::testSpecialPageDoesNotFatal with data set "RunJobs/JavaScriptTest" to Deprecated: Use of parserTest v1 in Scribunto and SyntaxHighlight.Apr 2 2020, 5:07 PM

Change 585546 had a related patch set uploaded (by C. Scott Ananian; owner: C. Scott Ananian):
[mediawiki/extensions/SyntaxHighlight_GeSHi@master] Update parserTests to v2 (tidy by default)

https://gerrit.wikimedia.org/r/585546

DannyS712 removed DannyS712 as the assignee of this task.Apr 2 2020, 5:18 PM
DannyS712 moved this task from Awaiting review and deployment to Others on the User-DannyS712 board.

Change 585548 had a related patch set uploaded (by C. Scott Ananian; owner: C. Scott Ananian):
[mediawiki/extensions/Kartographer@master] Update parserTests to v2 (tidy by default)

https://gerrit.wikimedia.org/r/585548

Change 585549 had a related patch set uploaded (by C. Scott Ananian; owner: C. Scott Ananian):
[mediawiki/extensions/Scribunto@master] Update parserTests to v2 (tidy by default)

https://gerrit.wikimedia.org/r/585549

Change 585550 had a related patch set uploaded (by C. Scott Ananian; owner: C. Scott Ananian):
[mediawiki/extensions/Disambiguator@master] Update to parserTests v2 (tidy by default)

https://gerrit.wikimedia.org/r/585550

Change 585550 merged by jenkins-bot:
[mediawiki/extensions/Disambiguator@master] Update to parserTests v2 (tidy by default)

https://gerrit.wikimedia.org/r/585550

Change 585546 merged by jenkins-bot:
[mediawiki/extensions/SyntaxHighlight_GeSHi@master] Update parserTests to v2 (tidy by default)

https://gerrit.wikimedia.org/r/585546

Change 585556 had a related patch set uploaded (by C. Scott Ananian; owner: C. Scott Ananian):
[mediawiki/core@master] Deprecate parserTests format v1 (take 2)

https://gerrit.wikimedia.org/r/585556

Change 585548 merged by jenkins-bot:
[mediawiki/extensions/Kartographer@master] Update parserTests to v2 (tidy by default)

https://gerrit.wikimedia.org/r/585548

Change 585549 merged by jenkins-bot:
[mediawiki/extensions/Scribunto@master] Update parserTests to v2 (tidy by default)

https://gerrit.wikimedia.org/r/585549

Both Scribunto and SyntaxHighlight_GeSHi have merged, should be safe to deprecate again

Change 585556 merged by jenkins-bot:
[mediawiki/core@master] Deprecate parserTests format v1 (take 2)

https://gerrit.wikimedia.org/r/585556