Page MenuHomePhabricator

Call to undefined method WikiPageMessageGroup::getKeys()
Closed, ResolvedPublic

Description

Error

MediaWiki version: 1.35.0-wmf.26

message
Call to undefined method WikiPageMessageGroup::getKeys()

Impact

Happening spikily, roughly once every few minutes.

Exports of message groups for offline translation is broken.

Notes

Details

Request ID
XoY1@gpAIIQAAlfSCJUAAABC
Request URL
https://meta.wikimedia.org/w/index.php?title=Special:ExportTranslations&language=eo&group=page-Category%3AInternationalization+templates
Stack Trace
exception.trace
#0 /srv/mediawiki/php-1.35.0-wmf.26/extensions/Translate/specials/SpecialExportTranslations.php(45): SpecialExportTranslations->checkInput()
#1 /srv/mediawiki/php-1.35.0-wmf.26/includes/specialpage/SpecialPage.php(575): SpecialExportTranslations->execute(NULL)
#2 /srv/mediawiki/php-1.35.0-wmf.26/includes/specialpage/SpecialPageFactory.php(618): SpecialPage->run(NULL)
#3 /srv/mediawiki/php-1.35.0-wmf.26/includes/MediaWiki.php(299): MediaWiki\SpecialPage\SpecialPageFactory->executePath(Title, RequestContext)
#4 /srv/mediawiki/php-1.35.0-wmf.26/includes/MediaWiki.php(973): MediaWiki->performRequest()
#5 /srv/mediawiki/php-1.35.0-wmf.26/includes/MediaWiki.php(535): MediaWiki->main()
#6 /srv/mediawiki/php-1.35.0-wmf.26/index.php(47): MediaWiki->run()
#7 /srv/mediawiki/w/index.php(3): require(string)
#8 {main}

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 2 2020, 7:02 PM
Jdforrester-WMF added a subscriber: Nikerabbit.

New in wmf.26.

Happens after:

		// Do not show this error if no/invalid format is specified for translatable
		// page groups as we can show a textarea box containing the translation page text
		// (however it's not currently supported for other groups).
		if ( !$msgGroup instanceof WikiPageMessageGroup
			&& !in_array( $this->format, self::$validFormats )
		) {
			$status->fatal( 'translate-export-invalid-format' );
		}

Looks like this was caused by rETRA7492129cf85b: Special:ExportTranslations: Disallow exporting huge groups@Nikerabbit, is this working on TWN?

Yep the issue is also affecting translatewiki.net. I failed to think it would affect production as well. I made a patch for it already: https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Translate/+/585444 - alternatively reverting the patch you mention is also okay.

Change 585444 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/Translate@master] MessageGroup: Add getKeys method

https://gerrit.wikimedia.org/r/585444

Change 585583 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/Translate@master] Revert "Special:ExportTranslations: Disallow exporting huge groups"

https://gerrit.wikimedia.org/r/585583

Change 585584 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/Translate@wmf/1.35.0-wmf.26] Revert "Special:ExportTranslations: Disallow exporting huge groups"

https://gerrit.wikimedia.org/r/585584

I've marked this as a blocker of next week's train.

Change 585584 merged by jenkins-bot:
[mediawiki/extensions/Translate@wmf/1.35.0-wmf.26] Revert "Special:ExportTranslations: Disallow exporting huge groups"

https://gerrit.wikimedia.org/r/585584

Mentioned in SAL (#wikimedia-operations) [2020-04-02T19:53:44Z] <jforrester@deploy1001> Synchronized php-1.35.0-wmf.26/extensions/Translate/specials/SpecialExportTranslations.php: T249258: Revert 'Special:ExportTranslations: Disallow exporting huge groups' (duration: 00m 59s)

Change 585444 merged by jenkins-bot:
[mediawiki/extensions/Translate@master] MessageGroup: Add getKeys method

https://gerrit.wikimedia.org/r/585444

Change 585583 abandoned by Nikerabbit:
Revert "Special:ExportTranslations: Disallow exporting huge groups"

Reason:
Not needed since https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Translate/ /585444 was merged.

https://gerrit.wikimedia.org/r/585583

Nikerabbit closed this task as Resolved.Apr 6 2020, 8:24 AM

Deployed and tested on translatewiki.net.

Nikerabbit reopened this task as Open.Apr 7 2020, 6:33 AM

Change 586516 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/Translate@master] Really fix fatals on Special:ExportTranslations

https://gerrit.wikimedia.org/r/586516

Change 586516 merged by jenkins-bot:
[mediawiki/extensions/Translate@master] Really fix fatals on Special:ExportTranslations

https://gerrit.wikimedia.org/r/586516

zeljkofilipin triaged this task as Unbreak Now! priority.Apr 7 2020, 11:32 AM
zeljkofilipin added a subscriber: zeljkofilipin.

Train blockers are UBN.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptApr 7 2020, 11:32 AM
Nikerabbit closed this task as Resolved.Apr 7 2020, 12:16 PM

Re-tested.