Page MenuHomePhabricator

[AMC] Regression on History page in Advanced Mode
Closed, ResolvedPublic3 Estimated Story Points

Description

Description

  • too much spacing

Developer notes

Basically requires a core change. The reason this regressed is that there is not a unique selector for this element (mw-changeslist-links is used by the user links too).

Option 1

The space is caused by an invisible line of text.


If this was wrapped in a span (core code change), we could display: none this to get:

Option 2

The undo and rollback link are wrapped in two span elements inside an element mw-changeslist-links. Annoyingly there are multiple mw-changeslist-links. A core change could add a new class to make this distinguisable from the other elements.

`
.mw-changeslist-links.unique-class > span { display: inline-block; float: right; }
`

QA Results - Beta|Prod

ACStatusDetails
1T249518#6165772

Event Timeline

Restricted Application added subscribers: Masumrezarock100, Aklapper. · View Herald TranscriptApr 6 2020, 4:41 PM
alexhollender updated the task description. (Show Details)Apr 6 2020, 4:43 PM

@alexhollender: Assuming this task is about the Advanced Mobile Contributions code project, hence adding that project tag so other people who don't know or don't care about random team tags can also find this task when searching via projects.

Alex is this still an issue?
https://en.wikipedia.beta.wmflabs.org/wiki/Spain?useskin=minerva&action=history looks fine to me


(rollback button [1] aside)

[1] note most users are not rollbackers :-)

Alex is this still an issue?

Hmm, it's looking better in production but still some issues with spacing

Jdlrobson updated the task description. (Show Details)Apr 21 2020, 3:45 PM
Jdlrobson awarded a token.
ovasileva triaged this task as High priority.May 4 2020, 3:18 PM
ovasileva set the point value for this task to 3.May 6 2020, 4:45 PM

Change 594962 had a related patch set uploaded (by Jdrewniak; owner: Jdrewniak):
[mediawiki/skins/MinervaNeue@master] Small fixes to AMC history page items

https://gerrit.wikimedia.org/r/594962

Jdrewniak claimed this task.May 7 2020, 2:21 PM
Jdrewniak added a subscriber: Jdrewniak.

This is what I hope the patch above results in. Haven't tested all the permission levels though.

Change 594962 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Small fixes to AMC history page items

https://gerrit.wikimedia.org/r/594962

Change 595492 had a related patch set uploaded (by Jdrewniak; owner: Jdrewniak):
[mediawiki/skins/MinervaNeue@master] AMC history page visual fixes

https://gerrit.wikimedia.org/r/595492

Looking at the changes from 594962 (merged) on Beta, looks like that patch had the desired effect on the (cur|prev) links, but only fixed the extra spacing for admin users. The last patch 595492 should take care of the spacing between the comments and diff-size for all users.

(it also places the tags on the same line as the undo button, to avoid that blank line between the two).

Jdrewniak removed Jdrewniak as the assignee of this task.May 11 2020, 5:29 PM

I'll review this today.

Change 595492 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] AMC history page visual fixes

https://gerrit.wikimedia.org/r/595492

alexhollender removed alexhollender as the assignee of this task.May 14 2020, 6:15 PM

back in business!

@Jdlrobson @Jdrewniak do we need to QA functional stuff here (I clicked around a bit), or is a visual design review enough?

@alexhollender the changes were only in CSS, so I think I visual design review is enough.

Edtadros reassigned this task from Edtadros to Jdrewniak.May 25 2020, 5:24 PM
Edtadros added a subscriber: Edtadros.

Test Result - Beta

Status: ❓ Need more info
Environment: beta
OS: macOS Catalina
Browser: Chrome
Device: MBP
Emulated Device: iPhoneX

Test Artifact(s):

QA steps

❓ AC1: @Jdrewniak from what I can understand this page should look like this:


from T249518#6137976

I get the following:

❓ I don't see the rollback or checkboxes. If this is just a permissions issue then this passes. Please assign it back to me and I'll update the description and these test results.

Jdrewniak reassigned this task from Jdrewniak to Edtadros.May 26 2020, 8:29 AM

@Edtadros yup, the checkboxes and rollback buttons are for users with admins privileges only. I don't notice anything else off on the screenshots you posted.

< here's with the rollback and checkbox

Thanks @Jdrewniak and @Jdlrobson. I'll update this and pass it now.

Edtadros reassigned this task from Edtadros to ovasileva.May 26 2020, 4:13 PM

Test Result - Beta

Status: ✅ PASS
Environment: beta
OS: macOS Catalina
Browser: Chrome
Device: MBP
Emulated Device: iPhoneX

Test Artifact(s):

QA steps

✅ AC1: This page should look like this:


from T249518#6137976

Actual

Rollback and checkboxes are missing due to permissions. Those were verified here: T249518#6165631

Edtadros updated the task description. (Show Details)May 26 2020, 4:13 PM
ovasileva closed this task as Resolved.May 26 2020, 4:17 PM

Looks good!