Page MenuHomePhabricator

Section edit icon not displaying in Minerva skin
Closed, ResolvedPublic

Description

Can't see "edit" icon for section headings on mobile

For whatever reason I can't see any "edit pencils ✏ " (or pens) while I use the "Mobile view".

I have this issue on all Wikimedia websites, and started experiencing it sometime after 21:00 (Central European Time).

QA Results - Prod

ACStatusDetails
1T249864#6053640

Event Timeline

DonTrung created this task.Apr 9 2020, 7:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 9 2020, 7:25 PM

I forgot to note that I do see them on the top of the page, just not anywhere else.

I also have it, the button works, only the pencil is missing

Gustmd7410 removed a subscriber: Gustmd7410.
Kipod added a comment.EditedApr 10 2020, 5:37 AM

fwiw, i added to mediawiki:minerva.js on hewiki the following line, and the pencils are visible again.

$(function() {$('h2.section-heading a').addClass('mw-ui-icon-wikimedia-edit-base20'); } );

this is not a "solution", but it will re-enable mobile section edit, until a real fix is deployed, if you want it on your wiki. true, section edit is still possible, if the editor knows that an "invisible button" is there, but most do not know this secret.

peace.

@Kipod , thanks for creating the (provisional) solution.

Aklapper renamed this task from Can't see "edit pencils" on mobile to Can't see "edit" icon for section headings on mobile.Apr 10 2020, 8:06 AM

@DonTrung: Hi, please always include browser / operating system information, clear steps to reproduce, links.
Please see and follow https://www.mediawiki.org/wiki/How_to_report_a_bug when creating tasks - thanks.

Lol this is funny.. invisible pencil

Xaosflux renamed this task from Can't see "edit" icon for section headings on mobile to Section edit icon not displaying in Minerva skin.Apr 10 2020, 3:17 PM
Xaosflux updated the task description. (Show Details)
Xaosflux added a subscriber: Xaosflux.

Also broken in desktop view, if using minerva skin

Added @Kipod 's patch to enwiki.

Change 588021 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/MinervaNeue@master] Update the icon glyph

https://gerrit.wikimedia.org/r/588021

Change 588021 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Update the icon glyph

https://gerrit.wikimedia.org/r/588021

4nn1l2 added a subscriber: 4nn1l2.Apr 10 2020, 10:46 PM

Now I can see the edit icons in English Wikipedia, but not yet in Korean Wikipedia.

Now I can see the edit icons in English Wikipedia, but not yet in Korean Wikipedia.

The relevant patch has not been deployed to any production wiki. English Wikipedia employed a temporary hack at en:MediaWiki:Minerva.js. You can use it if necessary.

Larske added a subscriber: Larske.Apr 11 2020, 6:53 PM
Jmar67 added a subscriber: Jmar67.Apr 11 2020, 7:00 PM

Sorry, please delete. New here.

Thought I had added an action. Please ignore.

The temporary fix applies to level 2 (h2) only. I do not see pencils at level 3, but can still edit.

Urbanecm triaged this task as High priority.Apr 11 2020, 7:12 PM
Urbanecm added a subscriber: Urbanecm.

Rendering the mobile edit interface useless. This could be backported on Monday.

Xiplus added a subscriber: Xiplus.Apr 13 2020, 2:22 AM
Stryn added a subscriber: Stryn.Apr 13 2020, 12:21 PM

Change 588405 had a related patch set uploaded (by Niedzielski; owner: Jdlrobson):
[mediawiki/skins/MinervaNeue@wmf/1.35.0-wmf.27] Update the icon glyph

https://gerrit.wikimedia.org/r/588405

Change 588405 merged by Niedzielski:
[mediawiki/skins/MinervaNeue@wmf/1.35.0-wmf.27] Update the icon glyph

https://gerrit.wikimedia.org/r/588405

Mentioned in SAL (#wikimedia-operations) [2020-04-13T19:02:46Z] <niedzielski@deploy1001> Synchronized php-1.35.0-wmf.27/skins/MinervaNeue: SWAT: [[gerrit:588405|Update the icon glyph (T249864)]] (duration: 01m 00s)

I could see "the edit pencil ✏" again, I think since yesterday. Thanks everyone for your hard work "behind the curtains", keep being awesome. 😉

SWATted to 1.35.0-wmf.27 w/ the help of @awight \o/

Edtadros reassigned this task from Edtadros to ovasileva.Apr 13 2020, 11:49 PM
Edtadros added a subscriber: Edtadros.

Test Result - Prod

Status: ✅ PASS
Environment: beta
OS: macOS Catalina
Browser: Chrome
Device: MBP
Emulated Device: iPhoneX

Test Artifact(s):

QA steps

✅ AC1: Verify that the edit pencils appear in section headings on mobile.

enwikikowiki
ovasileva closed this task as Resolved.Apr 14 2020, 9:32 AM

All fixed! Thank you all :)

4nn1l2 removed a subscriber: 4nn1l2.Apr 14 2020, 10:06 PM
Jony added a subscriber: Jony.Jul 13 2020, 7:55 AM