Page MenuHomePhabricator

Merge vehidebetadialog and hidewelcomedialog URL parameters
Closed, ResolvedPublic

Description

The URL parameter for hiding the welcome dialog in visual mode (VE) is vehidebetadialog, but for source mode (NWE) it's hidewelcomedialog. This causes people to write code like this where they pass in both parameters.

It would be nice if there was only one parameter for this functionality instead of two.

Event Timeline

Catrope created this task.Apr 10 2020, 9:30 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 10 2020, 9:30 PM

Hi @Catrope. Can you please associate at least one active project with this task (via the Add Action...Change Project Tags dropdown)? This will allow others to get notified, or see this task when searching via projects. Thanks.

Sounds good. Let's deprecate one and check mwgrep for uses of the other.

Catrope claimed this task.Apr 15 2020, 10:10 PM

Change 589735 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget: Move shouldShowWelcomeDialog() to init

https://gerrit.wikimedia.org/r/589735

Change 589735 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget: Move shouldShowWelcomeDialog() to init

https://gerrit.wikimedia.org/r/589735

Ryasmeen removed a project: Editing QA.EditedMay 16 2020, 12:12 AM
Ryasmeen added a subscriber: Ryasmeen.

Need steps to reproduce.

matmarex added a subscriber: matmarex.
  1. Open new incognito (private browsing) window, visit https://en.wikipedia.org/wiki/The_Fighting_Temeraire?action=edit (or, edit any other page). You should see the welcome dialog.
  1. Open new incognito window, visit https://en.wikipedia.org/wiki/The_Fighting_Temeraire?action=edit&hidewelcomedialog=1. You should not see the welcome dialog.
  1. Open new incognito window, visit https://en.wikipedia.org/wiki/The_Fighting_Temeraire?action=edit&vehidebetadialog=1. You should not see the welcome dialog.

Note that you need to close and open a new window every time, since normally you see the welcome dialog only when trying to edit for the first time.

matmarex edited projects, added Skipped QA; removed Editing QA.Jun 1 2020, 6:10 PM

Pretty trivial I guess

ppelberg closed this task as Resolved.Sat, Jun 13, 1:54 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSat, Jun 13, 1:54 AM