Page MenuHomePhabricator

Custom main page of Translatewiki uses default fonts
Closed, ResolvedPublic

Description

Somewhere along the line, Translatewiki main page lost a font declaration, which makes it display in serif font (Times New Roman on Windows) for almost everyone. This happens both logged in and logged out.

Screenshot:

Previously reported in Support:
https://translatewiki.net/wiki/Thread:Support/Bugs_on_translatewiki.net

Event Timeline

stjn created this task.Apr 14 2020, 1:16 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 14 2020, 1:16 PM
Nikerabbit added a subscriber: Nikerabbit.

I guess the cause is same as T243286: Some visual styles affecting fonts are lost and fix will be same or similar.

This was reported on IRC too.

Change 589316 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/TwnMainPage@master] Fix font styles

https://gerrit.wikimedia.org/r/589316

Change 589316 merged by jenkins-bot:
[mediawiki/extensions/TwnMainPage@master] Fix font styles

https://gerrit.wikimedia.org/r/589316

abi_ triaged this task as Medium priority.Apr 17 2020, 10:04 AM

Hmm, I still see Serif fonts on the main page:

Ah, I was testing in Timeless, where it is expected (also likely the reason I did not notice this myself). Looks good in Vector:

Pginer-WMF closed this task as Resolved.May 7 2020, 1:15 PM