Page MenuHomePhabricator

Consider removing initial images batch
Closed, ResolvedPublic

Description

Now that the query performance issue has been fixed, we might not need to fetch a batch of popular images on the back end anymore. Fetching this batch in one way and all other batches in another way has caused some regressions and duplicate code, so we'd prefer to remove the initial batch if possible and just fetch everything on the front end.

This will have the positive side effect of showing categories for the first batch on the popular tab, which isn't happening now.

Event Timeline

AnneT created this task.Apr 15 2020, 9:59 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 15 2020, 9:59 PM

Change 591433 had a related patch set uploaded (by Anne Tomasevich; owner: Anne Tomasevich):
[mediawiki/extensions/MachineVision@master] Remove initial batch of popular images fetched by backend

https://gerrit.wikimedia.org/r/591433

Change 591433 merged by jenkins-bot:
[mediawiki/extensions/MachineVision@master] Remove initial batch of popular images fetched by backend

https://gerrit.wikimedia.org/r/591433

Ramsey-WMF closed this task as Resolved.Jun 5 2020, 5:49 PM
Ramsey-WMF added a subscriber: Ramsey-WMF.

Since categories are showing for the first batch of popular images now, I think we can assume this change worked and consider this closed.