Page MenuHomePhabricator

Estimate readership from Internet Explorer 8
Closed, ResolvedPublic

Description

Background

We have been discussing the level of support required for IE8 for our projects, in particular the desktop improvements project. We are interested in getting a realistic picture of current usage of IE8 across different languages and countries

Questions to be answered

  • Overall usage of IE8 (percentage of overall pageviews)
  • Are there any countries where usage is particularly high? In what places is in more than 1% of pageviews? More than 0.5%
  • Are there any wikis where usage is particularly high? On what wiki is in more than 1% of pageviews? More than 0.5%
  • What is happening in Italy? We have noticed that usage has significantly increased over the past month and that it does not follow the patterns of other wikipedias (see this heatmap and this bar chart. We are curious to see if this is due to the current pandemic, or potentially a bug

Event Timeline

ovasileva triaged this task as High priority.Apr 16 2020, 1:44 PM
ovasileva created this task.
ovasileva updated the task description. (Show Details)
ovasileva added a subscriber: Mayakp.wiki.
nshahquinn-wmf renamed this task from What is our current IE 8 Usage to Estimate readership from Internet Explorer 8.Apr 19 2020, 3:43 PM
nshahquinn-wmf added a subscriber: nshahquinn-wmf.

We will triage this request at our team meeting tomorrow (Mon, 19 Apr).

mpopov added a subscriber: mpopov.EditedApr 20 2020, 4:41 PM

In the past Nuria has pointed out that a lot of clients representing themselves as IE6/IE7/IE8+ are actually just bots. That will need to be taken into consideration.

@mpopov I thought we removed js support for IE8 a while back. See: https://phabricator.wikimedia.org/T118303 and https://github.com/wikimedia/mediawiki/blob/master/resources/src/startup/startup.js

Do not believe those UAs , most IE<insert-low-number-here> are bots

LGoto assigned this task to Mayakp.wiki.Apr 20 2020, 4:43 PM
LGoto edited projects, added Product-Analytics (Kanban); removed Product-Analytics.
mpopov added a subscriber: Nuria.Apr 21 2020, 10:02 PM

Numbers provided in this Google sheet.

  • Overall usage of IE8 (percentage of overall pageviews) : 0.21%
  • Also, None of the Countries or Wikis have IE8 usage close to 0.5%
  • Webrequest data from Mar 29,30,31 for "IE8" in 'Italy' suggests that the issue is being caused due to bot traffic mistakenly identified as user traffic.

I used Superset for overall pageviews from 01-01-2017 to 04-01-2020, breakdown of IE browser versions, wiki, country.. since it would be much faster than querying pageviews_hourly table.

Adding on to what @mpopov shared, when looking at the top 10 IE8 usage by Wiki table
en.wikipedia 413347020 32.66% 0.0693%
ru.wikipedia 390543946 30.86% 0.0655%
it.wikipedia 124524471 9.84% 0.0209%
fr.wikipedia 42696909 3.37% 0.0072%
es.wikipedia 42547391 3.36% 0.0071%
ja.wikipedia 42449381 3.35% 0.0071%
de.wikipedia 34459558 2.72% 0.0058%
commons.wikimedia 18319966 1.45% 0.0031%
pt.wikipedia 13586268 1.07% 0.0023%
ar.wikipedia 12831631 1.01% 0.0022%

I'd assume bots being a huge part of the Russian view counts as well.

@ovasileva : Here is information on the new Bot Detection methodology that Analytics was working on. This has been deployed to production.

ovasileva closed this task as Resolved.May 13 2020, 10:26 AM

All done here, thanks @Mayakp.wiki!