Page MenuHomePhabricator

Error in Echo extension upgrading to WebdriverIO 5
Closed, ResolvedPublic

Description

There is only one error that is not going away, here is Gerrit commit link

Echo

Jenkins Bot
quibble-vendor-mysql-php72-docker
wmf-quibble-selenium-php72-docker

The same error is on both the CI tests

  1. Echo flyout for notices appears when clicked @daily element (".oo-ui-popupWidget-popup") still not displayed after 5000ms element (".oo-ui-popupWidget-popup") still not displayed after 5000ms

✓ alerts and notices are visible after logging in @daily
✓ flyout for alert appears when clicked @daily
✖ flyout for notices appears when clicked @daily
✓ checks for welcome message after signup

Although the code for notices and alerts flyout is basically same, one works fine and other donot

Event Timeline

Ashuro07 created this task.Apr 19 2020, 7:57 AM
Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptApr 19 2020, 7:57 AM
Ashuro07 renamed this task from Error in Popups Extension Upgradation to Error in Echo Extension Upgradation.Apr 19 2020, 7:57 AM

Change 590284 had a related patch set uploaded (by Gaura87; owner: Gaura87):
[mediawiki/extensions/Echo@master] Upgrade WebdriverIO version to v5

https://gerrit.wikimedia.org/r/590284

Gaura87 added a subscriber: jbolorinos-ctr.EditedApr 19 2020, 10:37 AM

@Ashuro07 I think this is a bug in WebdriverIo waitForDisplayed method , when it finds more than elments then it consider first one only , So in this case both Notices and Alerts had same class so WebdriverIO consider only first one that is Alert so in case of Alert it works perfec but and in case of Notices it is still looking for dispaly of Alert . So I fix this by finding Notices element not by class but by its text and it worked. Let @zeljkofilipin and @jbolorinos-ctr review this.

Here is my commit
https://gerrit.wikimedia.org/r/590284

@Gaura87 Yeah, I saw that commit, trying to implement the same logic with my commit.
Let's wait for the review

Aklapper renamed this task from Error in Echo Extension Upgradation to Error in Echo extension upgrading to WebdriverIO 5.Apr 19 2020, 11:39 AM
zeljkofilipin triaged this task as Medium priority.
zeljkofilipin moved this task from Backlog 🔙 to In Progress 🔨 on the User-zeljkofilipin board.

Yeah, we made a significant change in introducing noticesFlyout(), if that's seems alright with you this issue is resolved

Well, you've reported the problem. If the problem is fixed, resolve the task. :)

Yes, I will go ahead and resolve it

Ashuro07 closed this task as Resolved.Apr 21 2020, 6:24 PM

Change 590284 abandoned by Zfilipin:
Upgrade WebdriverIO version to v5

Reason:
Different implementation in https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Echo/ /598198

https://gerrit.wikimedia.org/r/590284