Page MenuHomePhabricator

Rename BeforeParserrenderImageGalleryHook to BeforeParserRenderImageGalleryHook
Open, Needs TriagePublic


When creating the new hook interface class, there's no need to propagate the incorrect capitalization of the old hook.

This hook is deprecated, so I'm hoping to remove it entirely anyway, but hopefully we can at least get the right capitalization in LTS in case an important use case is found and we have to revert the deprecation and keep the hook.

Event Timeline

Renaming this would break some of the logic that generates the hook function names. A proposed alternative by @tstarling was to introduce hook aliases instead of actually renaming the hook itself. This would also allow us to alias some of the hooks that have double colons in the name (e.g. ApiMain::moduleManager) which as of now is converting the colons into underscores (e.g. ApiMain__moduleManager) which looks slightly awkward.